1

With QGIS 2.12, I am displaying polygon outlines as dotted lines. The Print Composer screen correctly displays those outlines as dots. Here's a screenshot from the Print Composer window, showing dotted lines:

enter image description here

However, when I Print Composer > Export to Image (or pdf) the output file displays solid lines, not dots. Here's a screenshot from the output pdf. Note the solid lines:

enter image description here

The same problem happens if I select dashed lines. I'd like to have dots or dashes in my output media instead of solid lines.

Is this a bug, or am I doing something wrong?

5

Just tested in 2.12 and in my case dashed / dotted polygon outline exports to PDF and Image as expected. If you use very thin outline like 0.1 and polygons have overlaps which seems to be your case with these squares, it might look like the lines are solid even if they are dotted.

Solution might be:

  1. use custom dash pattern with bigger spaces between dots
  2. use thicker outline
  3. convert polygons to outlines and remove overlaps
  • Thanks, you are correct. Additionally, the default output resolution (300 dpi), is too coarse to discern such narrow dots and dashes. I cannot find a way to increase dpi, so I will create a new question about that. – Stu Smith Nov 16 '15 at 5:36
  • @StuSmith you can set highr DPI in the print composer - Composition tab (usually on the right bottom) - Export resolution - Default is 300 dpi – Miro Nov 16 '15 at 22:29
  • Thanks, my Print Composer Composition panel was turned off. I turned it on with View > Panels > Composition. Interestingly, with my QGIS version, there is no Composition tab, but there is a Composition panel with the same options, so I am happy. – Stu Smith Nov 17 '15 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.