1

Well, my problem is that I have GeoServer installed over a Windows 7 x64 system with both Java (JRE 6u29) x32 and x64 installed and I can't project my layers on the website. The preview on GeoServer works fine, but it doesn't work on my site (it's a localhost server, a testing server)

I have Apache + OpenLayers + GeoServer.

I have tried Tomcat + OpenLayers + GeoServer (war) with similar results.

The server status shows JAI libraries marked as false. I say this because I think the problem may be on the JAI library. I searched about and found that JAI works only on x32 systems so I don't know how to solve this. I need to work with x64 architectures.

I tried to install JAI over the x32 version of Java but my server stop working after that.

My local call to GeoServer through OpenLayers Instance is this:

<script type="text/javascript">
    var mapa, capa;

    function init(){
        mapa = new OpenLayers.Map('mapwms'); 
        capa = new OpenLayers.Layer.WMS(
            "Catastro",
            "http://localhost:8080/geoserver/Catastro/wms",
            {layers: 'Catastro:Predios'}
        );

        map.addLayers([capa]);
        map.zoomToMaxExtent();
        map.addControl(new OpenLayers.Control.LayerSwitcher());
    }
</script>

So I need to figure out why the GeoServer preview is working and not my code.

I'm new on this kind of software so I need some help

I put "http://localhost:8080/geoserver/Catastro/wms" because that is how appear on the preview source code.

I'll really appreciate your help please ;)

NOTE: I've changed the question title to a more clear one ;)


SOLVED: Thanks all for your help. I follow your advice and my server is now working.

1

I am quite sure the problem is not with the JAI libraries because the layer preview in Geoserver works.

Try this: open to the layer preview and look at the source code. The preview uses exactly what you are using in the page you posted above. There you'll find all your answers (in the source code , I mean).

Happy learning.

P.S.: change the question title, if it is not about JAI, or future users could be misled

1

as @unicoletti says it is almost certainly not JAI as if it was the layer preview wouldn't work. More likely problems are javascript errors or the browser not being able to see the OpenLayers library.

The easiest way to see what's up is to add firebug to firefox and look at the console to see what the error is.

  • In fact i'm using firebug right now and it didn't find errors on the code. – Daeron Alcarin Nov 21 '11 at 13:14
0

If the preview is working and your code is not, it has nothing to do with geoserver, JAI or tomcat. You can limit yourself to searching problems in the browser or OpenLayers.

Are you using Firefox and firebug to debug what is happening? Serious webdevelopers can't do without.

0

Assuming your Windows 7 Operating System is with IIS 7.5 running on port 80 you have downloaded and installed Microsoft URL Redirection plug-in?

http://cartoninjas.pl/post/2010/10/12/Installing-GeoServer-on-Windows-7-%28x32-or-x64%29-and-IIS-75.aspx

  • It is only a test server running on Localhost. – Daeron Alcarin Nov 21 '11 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.