3

In geoserver, when I edit a postgis raster layer and click on the Dimensions Tab, I can't enable either of the Time or Elevation dimensions. The following message appears next to each of the respective enable checkboxes:

Time

Cannot enable, no attribute of type Date found

Elevation

Cannot enable, no attribute of type Number found

Where do I add these attributes? I do have a date column in my raster postgis table.

  • Not all raster sources support time and elevation. Try it with a netCDF or GRIB file. – BradHards Nov 17 '15 at 8:03
  • @BradHards The rasters are stored in a postgis database not on disk, so I'm pretty sure they are agnostic of file type. The rasters originated as GRIB files, but I used raster2psql to put them in the database and then deleted the GRIB files. – apricity Nov 18 '15 at 3:04
  • I'm sure you know what you're doing, but having quickly looked at the code, I'm pretty confident that the postgis source type does not do what you think it does. NetCDF, GRIB, ImagePyramid or ImageMosaic are the valid options. You can probably come up with something based on ImageMosaic, but I haven't tried it. docs.geoserver.org/latest/en/user/tutorials/… – BradHards Nov 18 '15 at 8:35
1

There is a simple answer, the ImageMosaic JDBC module, that you're using to read data from PostGis raster, does not support dimensions at all. You should try a simple file based ImageMosaic instead (you can still keep the mosaic index in the database if you want).

In case you really need dimensions support in the ImageMosaic JDBC module, have a look here: https://github.com/geoserver/geoserver/wiki/Successfully-requesting-and-integrating-new-features-and-improvements-in-GeoServer

  • Thanks, would you be able to shed light on my related question? What I've really been trying to do is get geoserver to grab a specific raster from a table of many rasters based on some column attribute in the table. I have hundreds of rasters with the same extent in the same table, each raster is just for a different time. – apricity Nov 23 '15 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.