2

I have a simple project — a base map and a gpx track. The basemap is from OpenLayers. I want to change the map the CRS to Arizona Central so I can use miles as units for QChainage.

When I change away from the default WGS84, my GPX track disappears.

I've tried to set the Layer CRS for the track. I've tried setting the CRS for the baselayer (the layer doesn't show), but then setting the CRS for the project from that layer (which at that time isn't showing), and then everything shows but the CRS has been reset to WGS84.

What am I doing wrong?

PS: I originally posted this at StackOverflow and saw another posting that suggested this was a better place to post.

1

The OpenLayers plugin requires a project CRS EPSG:3857 World Mercator to work properly.

If you want to work with other CRS, you can make a screenshot with Project -> Save as Image, load that as a raster file, and reproject it to your desired target CRS with Raster -> Reproject under a different name. You can do the same with your GPX track using Rightclick -> Save As ... choosing a different file type like ESRI Shapefile.

With all data reprojected to the same CRS, you can turn On-the-fly-reprojection OFF, and the data should remain in the same place.

  • Thank you for answering. But that doesn't seem to change things. Both 3857 and 4326 (WGS84) work. But with Arizona Central 2223, my GPX track disappears. – Greg Nov 26 '15 at 5:34
  • I guess your error comes from I've tried to set the Layer CRS for the track. That produces corrupted data in most cases. You have to use Save As ... on the untouched original data instead. – AndreJ Nov 26 '15 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.