1

I want to join Excel data (numeric) to a Shapefile in QGIS. Although the cells are defined as numbers in Excel, QGIS recognizes them as string. I tried also csv, csv (windows), txt, xls, xlsx, none of them worked out.

I remember 3 years ago I used a csvt-file in order to help QGIS to recognize the data. But aI also remember that I could join Excel sheet content as numbers 6 months ago without creating a csvt file...

  • 1
    Have you checked/sanitized the field? Meaning is it possible somewhere in that column there is a non-numeric character or null that might be preventing it from being recognized as numeric? Is the field header valid? – Chris W Nov 22 '15 at 20:07
1

Had a similar problem: Try to import it as csv and then via MMQGIS plugin -> Modify -> Text to Float

  • Thanks. I tried MMQGIS. I could change change the type of one coloumn from string to real. But when I try to join the data to the shapefile, all the columns (string, real) are NULL... – Enzo Baldini Nov 21 '15 at 21:26
  • do saved the data as e.g. shape before the join? – user16032 Nov 21 '15 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.