2

I use QGIS 2.12 64-Bit Version on Win7. I have a problem with red matrix wich show up around every label. I want to delete them or make them invisible. It looks like in the following screenshotenter image description here

Does somebody know how to solve this? enter image description here

2
  • Does this occur in the composer or in the main canvas in QGIS?
    – Joseph
    Nov 24, 2015 at 13:18
  • Both, composer and map canvas
    – DirkB.
    Nov 24, 2015 at 13:19

2 Answers 2

3

You have the setting for "Show label candidates" enabled. On the labeling tab for your layer properties, click the "Automated placement settings" button:

enter image description here

Then, uncheck "Show candidates":

enter image description here

1

I think this might be a new feature made available in QGIS 2.12 according to the Changelog:

The following is quoted from the website along with the images:

In the screenshot you can see that the Streets have the option “Discourage other labels from covering features in this layer” enabled. The red labels derived from polygon geometries are thus placed to avoid intersection with the street axis. You have to enable “Horizontal” or “Free” on the polygon layer in order to achieve proper results.

Image taken from website, link provided above

Therefore, try disabling the "Discourage other lavels from covering features in this layer" option.

Hope this helps!

3
  • It seems that this option belongs to the red matrix, i didn't had that Option "Discourage other labels from covering features in this layer" enabled. So, when i chose this option the red marks disappear but also the labelling.
    – DirkB.
    Nov 24, 2015 at 14:36
  • When you're showing all labels, in the Rendering tab there's an Obstacles option, try enabling/disabling this. I am just guessing because I haven't come across this issue, hopefully others can also advise :)
    – Joseph
    Nov 24, 2015 at 14:43
  • i currently tried to set a rule to define labels, so far without any obvious reason after i setted a rule but with same label settings as before the red matrix are now black.
    – DirkB.
    Nov 24, 2015 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.