3

Whenever i zoom in print composer it jumps either in or out in steps not smoothly. I can not zoom progressively neither can i choose an area by using the magnifier. I am working on a map of islands and they are either represented very small in a large mass of water or the outer islands are not visible anymore. It must be possible to exactly define the area that i want to represent in print composer. How do i do this?

  • Are you using the Move item content tool from Print Composer to zoom? – Joseph Nov 25 '15 at 10:58
  • yes I do. is there an alternative? – kwai Nov 25 '15 at 11:00
5

You can also hold Ctrl while zooming to zoom by smaller amounts.

3

In the QGIS main window, go to Settings > Options > Map Tools and change the Zoom factor to 1.1 (which is the minimum it can go):

Zoom Factor

Now when you zoom in/out in either the main QGIS canvas or the print composer, it should be much smoother.

Hope this helps!

2

When you select the map item, you can specify the scale and extents. When I make maps I usually set where I am mapping in the centre of QGIS (not the composer), then in composer use the 'Set to map canvas extent'.

This will centre the print composer on where you want it, then just play with the scale and hit the 'Update preview' button every time you alter it. This gives you a bit more control than using the mouse scroll wheel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.