1

I have installed the new version of QGIS (2.12) and the newest OSX version (El Capitan). When I tried to open GeoTif files with QGIS, it always crashed! Then I tried an older version of QGIS (2.8) and the same problem appeared! I don´t know what to do know and I hope there is anybody who is good with QGIS and MAC!

  • Which QGIS version are you using, KyngChaos, Homebrew, MacPorts or ... – gene Nov 26 '15 at 17:48
  • Here is the link of the page I´ve downloaded it: kyngchaos.com/software/qgis. So it seems to be the version QGIS 2.12.0-1. My macbook has the version Mac OSX 10.11.1 installed. – waldviertlerkartograph Nov 27 '15 at 7:55
  • Install Qgis On mac Os X El Capitan – gene Nov 27 '15 at 15:23
  • Thank you for your advice, but I´ve already done that all before and qgis also runs already on my mac! My only problem is, that I can´t open GeoTif files without crashing QGIS! When I start a project without GeoTif files, it works as it should! – waldviertlerkartograph Nov 27 '15 at 17:10
1

I was having the same issue with the package installed following the Kyngchaos website. I installed GIS 2.8 via Homebrew following this tutorial and now I'm able to import GeoTiff files.

Summary of the installation process:

brew install postgresql
brew install python  
export PYTHONPATH=/usr/local/lib/python2.7/site-packages:$PYTHONPATH  
pip install numpy scipy matplotlib processing psycopg2
brew install gdal 
brew tap osgeo/osgeo4mac  
brew install qgis-28  
brew linkapps qgis-28 
  • Did anyone find out what the problem was? and is it fixed? I am having similar trouble with QGIS 2.16.4. I have tried on 2.8.2 and still crashing. I am trying to open 1gb tiff files from Sentinel 1 on a Windows 7 64bit machine. Reinstalling on my work machine is not an option. – Johanna Sep 7 '16 at 3:47
  • I was experiencing this problem on 2.14. When I updated to 2.16 using the King Chaos build today I no longer had this problem. – clhenrick Sep 26 '16 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.