1

While making slippy map tile sets from a QGIS (2.10.1) project running on Vista 32, I've noticed some reduced image quality from QTiles 1.5.0 and QMetaTiles 1.0, versus the output from a rendered print composer (and subsequent fairly intricate workflow to end up with tiles).

In all cases, I'm exporting to .png, 256x256; the checkbox for 'Make lines appear less jagged...' was on for all these test cases, and the image quality setting (with .png selected, this is only adjustable in QMetaTiles, not QTiles) makes no discernable difference.

A few images are attached. The aliasing on the text is one thing, but the stairstepping and staggering on the contour lines is the main issue.

Can anyone explain why these differences occur, and/or point out a way to get the 'better' version using the QTiles or QMetaTiles plugins?

Composer workflow:

enter image description here enter image description here

QTiles:

enter image description here enter image description here

QMetaTiles:

enter image description here enter image description here

  • PS I am guessing this is beyond the control of the plugins, and it's just due to the fact that the rasterizer in the working view is lower quality than the rasterizer in the print composer. Anyone know for sure if that is the case? Is there a way to tell the scripts what rasterizer to use, or, are they locked in to using the lower quality one? – Tom Grundy Nov 29 '15 at 18:59
  • Actually, 'rasterizer' isn't the right term, since these are already raster layers in qgis, imported from .tif files which were created from layers of USTopo pdf quads. I double checked and the tif files themselves do have all the nice high resolution and smooth lines of the 'composer workflow' above. Also, the rendered image in the normal qgis working view has high resolution when you zoom in enough. As a reality check, I zoomed in pretty close in the working map view then exported tiles again - the resulting tiles still have the quality issues. So, maybe it's just the qgis renderer?? – Tom Grundy Nov 30 '15 at 16:40
  • I see the same thing using tilesets from Geowebcache. In QGIS, in the layer style properties, have you tried setting the resampling method to 'bilinear' or 'cubic' / 'average' and upping the oversampling? I find using bilinear / average / 5 improves the quality a lot but still not the same as using WMS direct from Geoserver. – mixedbredie Dec 23 '15 at 12:12
  • I did try the other resampling methods but they only provide very minimal improvement. I looked at the code a while but am not sharp enough with it to determine what the right solution would be. – Tom Grundy Dec 23 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.