8

I had done a few projects using Google Physical/Streets as basemaps but now when I re-open those projects all layers appear except for the google basemap (other layers include .kml).

I had previously had this issue when I had a poor internet connection - the basemap would not load - but I now have a good connection so that should not be the problem.

I have also tried starting a new project and adding Google Physical there but likewise nothing appears. In the old projects I have tried removing and re-adding the basemap but no luck.

I have tried uninstalling and re-installing the OpenLayers Plugin (version 1.3.6) but the problem persists. When I use the plugin to add OSM however it does work (but I need Google for these projects).

I have verified the CRS and have it set to WGS 84/Peudo Mercator EPSG:3857

I am using QGIS 2.8.2-Wien on Mac

How do I make Google Physical visible again?

20

Do not use the OpenLayers Plugin, it sucks. Use QuickMapServices instead. (see my comment below on why I think it sucks)


Or you can add the google tileserver directly as a raster layer.

Open up an XML file and paste this in:

<GDAL_WMS>
<!-- Data is subject to term of use detailed at http://code.google.com/intl/nl/apis/maps/terms.html and
 http://www.google.com/intl/en_ALL/help/terms_maps.html -->

<Service name="TMS">
    <!-- <ServerUrl>http://mt.google.com/vt/lyrs=m&amp;x=${x}&amp;y=${y}&amp;z=${z}</ServerUrl> --> <!-- Map -->
     <ServerUrl>http://mt.google.com/vt/lyrs=s&amp;x=${x}&amp;y=${y}&amp;z=${z}</ServerUrl> --> <!-- Satellite -->
    <!-- <ServerUrl>http://mt.google.com/vt/lyrs=y&amp;x=${x}&amp;y=${y}&amp;z=${z}</ServerUrl> --> <!-- Hybrid -->
    <!-- <ServerUrl>http://mt.google.com/vt/lyrs=t&amp;x=${x}&amp;y=${y}&amp;z=${z}</ServerUrl> --> <!-- Terrain -->
    <!-- <ServerUrl>http://mt.google.com/vt/lyrs=p&amp;x=${x}&amp;y=${y}&amp;z=${z}</ServerUrl> --> <!-- Terrain, Streets and Water  -->
</Service>
<DataWindow>
    <UpperLeftX>-20037508.34</UpperLeftX>
    <UpperLeftY>20037508.34</UpperLeftY>
    <LowerRightX>20037508.34</LowerRightX>
    <LowerRightY>-20037508.34</LowerRightY>
    <TileLevel>20</TileLevel>
    <TileCountX>1</TileCountX>
    <TileCountY>1</TileCountY>
    <YOrigin>top</YOrigin>
</DataWindow>
<Projection>EPSG:3857</Projection>
<BlockSizeX>256</BlockSizeX>
<BlockSizeY>256</BlockSizeY>
<BandsCount>3</BandsCount>
<MaxConnections>5</MaxConnections>
<Cache />
</GDAL_WMS>

Then load that XML file as a raster layer.

  • Changing EPSG:900913 to EPSG:3857 would eliminate the pop-up from QGIS asking what the projection is when the xml is first loaded. – SaultDon Nov 30 '15 at 20:51
  • 3
    Please specify why the OpenLayers plugin "sucks" – user2856 Nov 30 '15 at 22:45
  • 3
    I've used the plugin in QGIS since version 1.7 and almost never had good experiences with it. It was first released to provide a basemap functionality, provided that the layers actually decided to show up on the screen in the right place, and all your data was in 3857. Various updates would completely break the plugin and it was hit or miss which layers would work each day. Whereas you could add a WMS baselayer or tileserver and get on with it. To be fair, I did see very very recently they fixed some of the more egregious bugs (the google maps offset weirdness for one) so it's improving. – Thomas Dec 1 '15 at 16:27
  • 2
    @Luke OpenLayers has been giving me headaches for a few years: doesn't export or draw properly when used in layouts, Google layers never display correctly, layers are always added above vector layers, etc. - all of those issues are overcome with QuickMapServices plugin... – DPSSpatial Dec 1 '15 at 19:37
  • @mapBaker Oh yeah -- the drawing in layouts/print composer NEVER worked properly. It was unusable for that and pretty infuriating. – Thomas Dec 1 '15 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.