1

In ArcGIS Desktop 9.3 I have 3 features I'm trying to use to extract by mask a DEM raster layer. After I extract by mask the layers visually don't line up. When I try to do further analyses (e.g., extract to point, slope, summary stats, etc.) it is clear that my mask does not line up with my features because I get -999999 as values in further analyses.

What went wrong? and what can I do to fix it?

I'll also note that my features were originally drawn polygons that I converted to features -- could this have anything to do with the problem?

STEPS

  1. Create New layer

  2. Draw Polygon

  3. Manually adjust polygon length & width

  4. Rotate polygon

  5. Copy polygon 2x so that I have 3 identical polygons

  6. Place polygons where they belong on map (using road features layer as guide)

  7. Convert Graphics to features (using DEM as source data for coordinate system)

    • Selected all 3 drawn polygons at once and then selected to convert graphics to features
  8. Add new features as layer

    • Agreed to the menu that popped up asking to add my converted features as a layer
  9. Extract by Mask using new layer features as input and DEM for raster input

Properties of both Layers (I didn't manually define or adjust)

DEM Raster:

Spatial Reference: NAD_1983_StatePlane_North_Carolina_FIPS_3200_Feet
linear Unit: Foot_US (0.304801)
Angular Unit: Degree (0.017453292519943295)
False_Easting: 2000000.002616666
False_Northing: 0
Central_Meridian: -79
Standard_Parallel_l: 34.33333333333334
Standard_Parallel_2: 36.16666666666666
Latitude_ Of_ Origin: 33.75
Datum: D_North_American_1983

Polygon Features:

Projected Coordinate System:     NAD_1983_StatePlane_North_Carolina_FIPS_3200_Feet
Projection: Lambert_Conformal_Conic
False_Easting:  2000000.00261667
False_Northing: 0.00000000
Central_Meridian:   -79.00000000
Standard_Parallel_1:    34.33333333
Standard_Parallel_2:    36.16666667
Latitude_Of_Origin: 33.75000000
Linear Unit:    Foot_US

Geographic Coordinate System:   GCS_North_American_1983
Datum:  D_North_American_1983
Prime Meridian:     Greenwich
Angular Unit:   Degree

Overall Data Frame properties:

NAD_1983_StatePlane_North_Carolina_FIPS_3200_Feet
Projection: Lambert_Conformal_Conic
False_Easting: 2000000.002617
False_Northing: 0.000000
Central_Meridian: -79.000000
Standard_Parallel_1: 34.333333
Standard_Parallel_2: 36.166667
Latitude_Of_Origin: 33.750000
Linear Unit: Foot_US

GCS_North_American_1983
Datum: D_North_American_1983

Picture demonstrating alignment issue (2 of 3 drawn features shown)

Black/grey = DEM mask layer; Red outline = polygon feature outline; Blue = rivers; Green = roads enter image description here

  • In order to help I think we need you to edit your question to include a more precise description of each step you performed i.e. tool and parameter values. It may well be that, when you document precisely what you have done, where you are stuck will evaporate. – PolyGeo Nov 30 '15 at 19:29
  • 1
    additional to all the details @PolyGeo asked, are both your DEM and your polygon in the same projection? – yanes Nov 30 '15 at 19:35
  • 1
    Can you please upload a picture (snapshot)? I still don't seem to grasp what you mean by not aligning? Did you extract the DEM at three different places? or did you extract it three times using three different overlaying polygons (at the same spot)? – yanes Nov 30 '15 at 20:46
  • 1
    Yes - Layers is the default data frame name, and that is important information to include in your question. – PolyGeo Nov 30 '15 at 20:55
  • 1
    It looks like, this has to do with the cell resolution of your DEM! if you zoom really right in, you will see that the size of the cells are bigger than the gap created between the DEM and the polygon outlines. Therefore, you either work with these extracts. OR if you would like a perfect area that fills the polygons you have to RESAMPLE your DEM into a smaller cell value! but beware resampling also introduces its own error as you will simply interpolate. But depending on the objective of your study it might not affect you much. – yanes Nov 30 '15 at 21:12
3

It looks like, this has to do with the cell resolution of your DEM. If you zoom really right in, you will see that the size of the cells are bigger than the gap created between the DEM and the polygon outlines. Therefore, you either work with these extracts. OR if you would like a perfect area that fills the polygons you have to:

  1. RESAMPLE your DEM into a smaller cell value! Use the 'resample' tool for this. But beware resampling also introduces its own error as you will simply interpolate. But depending on the objective of your study it might not affect you much.

  2. Use Extract by mask to extract the area of the DEM you are interested in using the polygon features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.