2

I have used ArcGIS extensively, but am at a new job with only access to QGIS. I am trying to import a few shapefiles and am having some problems. First, I opened the shapefiles in esris free browser, and eveything opened without a problem.

I open the files in QGIS and they are loaded browser panel showing that they are polygon and polyline, respectively, but no features are displayed on the screen. Further, when I click zoom to features, I am taken to the right place, which indicates that something is there.

I ran the check geometry validity and got an error of Unknown geometry Type 0. However, I looked in the metadata and it correctly displays its geometry type.

Data can be found at the link below: Click "project documents" tab, and then download "other/2d benchmarking data" I am looking at the shapefiles in "Test 5". I tried shapefiles in the other "test" folders and those seemed to be working fine:

http://evidence.environment-agency.gov.uk/FCERM/en/Default/FCRM/Project.aspx?ProjectID=669DA341-AE12-494F-9E53-29C6633FA0CD&PageId=a0fe6dfc-506a-452c-9bff-a7ec06b4e6b0

  • Sample data would help a lot. – user30184 Dec 3 '15 at 21:47
  • 1
    Have you installed the GEOS framework ? – gene Dec 4 '15 at 8:57
  • Sample data has been added, if anyone can look at it. – Brian F Dec 4 '15 at 16:45
  • I have not installed the GEOS framework... I could find documentation as this relates to QGIS – Brian F Dec 4 '15 at 17:32
  • Checking your data with orginfo I got fread error ogrinfo -al Test5ActiveArea_region.shp, I've loaded your data into ArcGIS and exported them to a new shape file to fix it. I suppose some special characters are in the header of the shp. You can download the corrected files from here geod.bme.hu/siki/test5.zip – Zoltan Dec 4 '15 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.