I have a large data set collected by a GPS collar on a cow that I am trying to animate with the Time Manager plugin to show the cow's movement throughout a pasture. I have the data saved in a .shp file that displays correctly. When I turn on the TM plugin and go through the settings then click "OK" all my points disappear from the canvas. I click "play" and the plugin appears to progress through time, but no points display. I noticed when I try to open the attribute table while the plugin is on nothing displays, but when I switch it off everything reappears.

Attached are some screenshots of my settings and what I am seeing: https://i.sstatic.net/5CVAI.jpg Settings

https://i.sstatic.net/faM9n.jpg TM on

https://i.sstatic.net/PwAbR.jpg TM off

I have double checked time format and it is in YYYY/MM/DD HH:MM format. I can see the time stamp in the corner of the map progressing through but no points display at all.

  • Please do not include signatures, thanks, etc within questions and answers here. Every post you make is already signed with your user card, while you should think of the Q&As as wiki pages rather than personal communications.
    – PolyGeo
    Dec 4, 2015 at 5:32
  • After playing around some more I have got the plugin to display a few points, but not all. Is there some limit to the number of points this plugin can handle? I have about 14000 features in my shapefile and can only get about the last 3000 to display. I've tried everything I can think of; reinstalling the plugin, starting a new QGIS project with just the ortho photo and shapefile, recreating the shapefile to just contain time and Northing/Easting info. I'm at a loss here.
    – bschiltz
    Dec 7, 2015 at 22:09
  • Please use the edit button beneath your question to revise it with improvements to your original question such as this: meta.gis.stackexchange.com/a/3353/115
    – PolyGeo
    Dec 7, 2015 at 22:20

2 Answers 2



It appears the time format was causing issue with the plugin. I only included yyyy/mm/dd hh:MM in my data since the time interval was 10 minutes, however this caused unstable behavior with the plugin. After adding seconds to the data the plugin appears to be working as expected.


Edit: After further testing it appears the problem was related to exporting the .csv file from MS Excel. I believe Excel was truncating 0s from both the date and time values, thus causing the unstable behavior. It appears using "Format Cells ->Custom" in Excel and defining the date/time format manually preserves the correct date and time values.


A little late on this, but I had the same issue and thought this might be of use to others. My time field was a Python Datetime type, in the '%Y-%m-%d %H %M' format. QGIS recognizes this as a datetime format, but TimeManager didn't like it. After reading bschiltz's answer I tried converting my datetime format to epoch time, and found that TimeManager likes epoch time. My time-series animations now work perfectly.

This is the code I used to convert to epoch time, just added .timestamp() to the end of my conversion from string to datetime:

datetime.strptime(<date_and_time_string>, '%Y-%m-%d %H %M').timestamp()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.