I am trying to geocode some coordinates I have from my Excel sheet onto ArcGIS but everytime I do so, it doesn't show up on the screen. When I right click on the sheet layer to see where it went, it shows my points as this:

Points are aligned straight down the middle

Here is also a photo of what my attribute table looks like:

enter image description here

I have tried multiple times removing it, restarting ArcMap and but this still happens. Before, it used to display all my longitude points as 0, but since then I have tried tweaking around on my Excel sheet.

This has never happened before. Could it have something to do with ArcMap not being able to read the decimal placements since they are not aligned perfectly.

I also made sure to pick my X value to be my longitude, and Y value as latitude.

Can anyone explain why this is happening?

  • Those look like properly formatted numbers to me. You can always check/force it to be a numeric column, but I doubt that is where your issue lies. Dec 7 '15 at 10:10
  • Have you set Coordinate System of Input Coordinates to GCS_WGS_1984 in Add XY Data windows?
    – Marcin
    Dec 7 '15 at 11:19
  • @Marcin Yeah I have set it to a geographic coordinare system
    – Chai.Tea
    Dec 7 '15 at 14:57
  • @JohnBarça my columns for the lat and long are in numbers already. I did that prior to dragging it in arcmap
    – Chai.Tea
    Dec 7 '15 at 14:58

I had the same problem and simply convert .xlsx to .csv only helped to display the x coordinate. I used the table to table file to create a new table from the .csv file and define the field type to be numeric. After that it worked. To me it seems to be more of an excel problem rather than an ArcGIS 10.3 problem...


So turns out when I convert my excel file to a csv file it finally worked.

I guess it won't work on a newer version of excel (on a Mac).


It looks like your X (Longitude) is coming over as an integer, thus ignoring all the decimals while the Y is coming in correct.

When teaching many students using excel would hit a space in a cell making the field come over into ArcMap as a text, preventing you from even being able to plot the points. The CSV option gets around this by stripping away the formatting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.