1

I am executing an ArcGIS server Export Map operation /service. The JSON response returns a property called imageData, and not the expected href property containing the Url to the generated png file. I tried a different ArcServer with the exact request and get back the expected result. The MapServer endpoint lists the following Supported Image Format Types: PNG32,PNG24,PNG.

What needs to be done to the ArcServer to return the expected PNG Url?

Current Response:

{
"imageData": "iVBORw0KGgoAAAANSUhEUgAABRQA...
"contentType": "image/png",
"width": 1300,
"height": 385,

Expected Response:

{
"href": "http://myserver/arcgis/rest/directories/arcgisoutput/Dir/MyMapServer/abcd.png",
"width": 1300,
"height": 385,
....

2 Answers 2

1

I'll describe what worked for me in such situation. Firstly I saved the map the map service is based on(say, map1.mxd) with other name (say, map2.mxd). By the way its size decreased twice. Then I created a new map service based on map2. It worked fine: I got href in Export operation. Then I deleted the old service and map1.mxd , renamed map2 to map1 and recreated the old map service. The problem was fixed.

0

I have also experienced the same issue with 10.6 services that answer instead of , but my problem happens randomly, I think. I also noticed that in case of publishing directly from ArcMap 10.6 I have this problem (imageData response);

instead if I create a .sd file and publish it from the web manager then the service returns correctly the href.

Did you find out something about this behaviour?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.