2

While trying out the Size Assistant feature I encountered a problem. I´m working with this csv Table:

Used csv table

I tried to resize the Point Size based on the field „Anzahl Objk“ and to do this I went to „Layer Properties“ – „Style“ clicked on the Data defined override Button next to the „Size field“ and selected „Size assistant“ at the bottom. In the following window I changed the settings like this:

Size Assistant Settings

I clicked o.k. expecting to see values from 1 to 5 in the size of the yellow dot with the no „5“ next to it in the picture above. values from 6 up would then be in the size of the dot with the „10“ next to it. After clicking o.k I got a red tinged button like this next to the size field

Error indicated next to size field

And hoovering over it and in the description window it reports the following error:

Error description

If I click on Edit in the button menu I get to the expression builder where it reports the same error.

The points on the map don´t change at all. Is there a way to get this to work easily the way I expect it to with this assistant by doing steps differently or do I have to enter or change an expression code somewhere? Or do I completely misunderstand the dialog above and what it is supposed to do?

1 Answer 1

2

When you click the Edit button to get the expression builder, you might see an expression like:

Expression string builder

Try putting the field name inside double quotation marks ( " " ) like this:

Expression string builder with correct expression

The error should disappear and hopefully you will see your points.

2
  • 1
    works, thanks for the help! Should I report this as a bug somewhere?
    – Taya
    Dec 10, 2015 at 14:35
  • @Taya - Most welcome! I would think it is a bug, they did update the Field Calculator to take into account field names without the need for the double-quotes but it seems this wasn't extended to the Expression string builder. If you wanted to, you can send a bug report, note that you will need to create an account beforehand :)
    – Joseph
    Dec 11, 2015 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.