2

I am using GRASS 7 for windows, and I'm having trouble running v.in.ascii, although I'm fairly sure I've run it successfully before. When I run v.in.ascii, I get an error: Windows can't open this file. enter image description here

This happens through the command line and the gui. Other v.*.exe commands seem to run properly.

I thought maybe there was a path clash somewhere, so I generally cleaned up my path variable (e.g., removing OSGeo4W/bin). I also reinstalled GRASS 7. I searched GRASS bugs, but didn't find something similar. Other than that, I haven't been able to find anything on google to help explain this, and I've run out of ideas.

Recently, IT installed hard drive encryption software. This and a couple problems popped up about the same time, so I have a sneaking suspicion that it's related.

Edit: some additional information that @GeoStoneMarten helped me tease out:

  • From the GRASS shell, if I cd to C:\grass70\bin, then v.in.ascii works

  • v.in.ascii is the only v.* command that gives me this error

  • C:\grass70\bin is being added to the path variable correctly upon calling grass70.bat

  • have you check in install folder if v.in.ascii.exe exists? – GeoStoneMarten Dec 8 '15 at 14:13
  • @GeoStoneMarten Thanks for the help. Yes, C:\grass70\bin\v.in.ascii.exe exists. It's also more than 0KB - I was curious about that too. – user55937 Dec 8 '15 at 14:20
  • i check it on grass 6 and size = 126 Ko (129 550 octets) i install wingrass 7 and comeback – GeoStoneMarten Dec 8 '15 at 14:47
  • Thanks again for taking the time. Just FYI, v.in.ascii.exe is 129 kb on my machine, so I imagine the executable is intact. – user55937 Dec 8 '15 at 15:00
  • this is equivalent for me (128kb). Are you running from *.bat because *.bat set PATH at starting application. in addition check if v.in.ascii.bat exist and it content – GeoStoneMarten Dec 8 '15 at 15:26
1

I don't know why, but there was a 0 kb file called v.in.ascii in C:\Users\username. I deleted that file and everything works again.

Edit: Just a quick update. I usually call GRASS from Windows' absolutely deplorable command prompt (I shouldn't do that). If I mistype a command, I can't hit the up button to recover what I had typed so that I can try again. So instead I copy and paste the command to not start from scratch. In my haste, I copied the directory and tried to execute C:\Users\username>v.in.ascii ..., which results in a sensible error but succeeds in redirecting nothing to a file called v.in.ascii, thus blocking me from using that module. Mystery solved. My error, but I blame Windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.