I am attempting to use the dissolve tool on a shapefile, but it fails with the error:

ERROR 999999: Error executing function.
Invalid Topology [Duplicate segment.]

I tried checking and repairing geometry until no more geometry errors exist. I also tried the fix topology error tool, but the topology edit tool says that no topology exists. Any ideas why this might be happening?

  • The Duplicate segment warning may be the key. Have you tried running Find Identical? (Repair Geometry doesn't look for duplicate polygons/lines.) – Erica Dec 8 '15 at 14:55
  • Thanks for the advice. I found many duplicate rows, so I ran delete identical and got rid of them. However, the dissolve tool still failed with the same error. – Anthony To Dec 8 '15 at 17:15
  • Importing into a GDB worked! Thanks so much for the guidance. Feel free to make an answer and I'll mark it as accepted – Anthony To Dec 8 '15 at 19:53
  • Thank you -- I answered it more or less the same as I commented, just in case (a) both approaches were necessary to resolve it and (b) it helps somebody with a similar problem in future :) – Erica Dec 9 '15 at 1:04

One possible solution is running Find Identical, since the error specifies "Duplicate Segment" -- Repair Geometry doesn't look for identical features, just for invalid geometries.

Sometimes ArcMap just doesn't like shapefiles as well as feature classes in a geodatabase, so converting to a GDB and then trying again is another possible solution.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.