1

I am trying to export a excel sheet to a shapefile where I am performing the below shown steps:

Step 1: I right clicked on the excel sheet which I wanted to export into a shapefile and selected Display XY Data as seen in the imageenter image description here

Step 2: After this step a Sheet$Events layer was added in my TOC. On which I right clicked and performed export data to export it to a shapefile.

Step 3: After opening the attribute table, I have a mismatch in the values as they are rounding off.enter image description here

I don't want these values to round off. It is affecting my analysis. I can't find a way to solve this problem. Please help!

  • Have you tried exporting to GDB? See here. – Paul Dec 9 '15 at 6:15
  • Thank you Paul for replying. I read the suggested answer before but since I am new to using this software I didn't understand what was mentioned in that answer. Although I did try the last answer which asked to click on 3 gray dots, but that didn't work. – Divya Dec 9 '15 at 6:39
  • When you say "didn't work", you should always say what happened instead. We can't see your screen, so you have to describe the error message, incorrect result or explosion :-) – BradHards Dec 9 '15 at 6:53
  • @BradHards Sorry about that. I meant there was no change. – Divya Dec 9 '15 at 7:09
  • What's the output field type? Is it an integer? Try setting the field in Excel to Text instead. Weird. I just tried it (on a 10.4 dev machine) and it worked fine. The output field type was double. Column type in Excel was General. – mkennedy Dec 9 '15 at 17:58
2

I find issues like this are often related to what Excel formats columns of data as. You might try again, after having made all your numerical columns of type 'General' in Excel and saving the .xlsx file.

If there are no commas in the file (e.g., in names, etc), another way is to export the Excel sheet to non-proprietary .csv, which rarely sees strange behavior like this going into ArcMap (and you can import x,y data in the same way).

  • Thank you for the reply Paulo. 1. I changed the format of the column to General but got same result. 2. I tried with CSV file and this time it truncated one digit from right. eg. 1774888229 was changed to 177488822 – Divya Dec 9 '15 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.