1

I am creating a map within the CartoDB map creator based on a dataset (spatially located within CT timezone) with a timestamp range of "2015-11-19 11:00:00' AND '2015-11-19 17:00:00" (UTC) but when animating the map based on timestamp the animated time legend displays a range of "03:00 AND 09:00" (which is incorrect).

Is it possible to turn off this auto-correction and display the original time while using Torque?

1

Torque is adjusting the times in the data (which are in UTC), using the time zone of the machine upon which you are viewing the visualization. To test this, simply change the timezone setting on your machine, and then replay the animation (may have to reload the visualization in your browser). The times show in the slider will be different.

This seems to have been a problem before Based upon the discussion of the issue on GitHub, there does not appear to be any way to change this behavior.

  • I deleted my response because I wasn't aware that there was actually an issue here. @tekim is totally right, I have reported the issue here: github.com/CartoDB/cartodb.js/issues/929 . Notice that you can set the appropriate timezone in the data so that Torque then shows the hours appropriately, but the issue will be fixed asap. – iriberri Dec 14 '15 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.