1

I'm consistently getting an error 000725 (Output Feature Class already exists) when trying to use the "points to line" tool in ArcMap 10.3

It's a points shapefile with 4 points and I just want to make them into a square outline. I've used this tool before and gotten this error, then rebooted my computer and it worked perfectly for multiple files for this exact same function. No luck this time.

I've rebooted, I've checked the "overwrite outputs" option under Geoprocessing options, I've created a new File Geodatabase in case the problem was that my default geodatabase was full. Now it's writing to a blank geodatabase, and being told to overwrite files, and STILL giving me the error that the file already exists. I've re-ordered my points within the shapefile to make sure they are in the correct order, I've tried converting my data to a shapefile through multiple avenues... I can't think of any other reason I'm getting this error.

I am using just the ArcToolbox: Data Management Tools > Features > Points to Line.

My input feature is a points layer shapefile that is visible on the map and in the table of contents

I've quadruple-checked every time that the output file name doesn't already exist, so it is not actually an overwrite problem as far as I can understand. And I leave Line Field and Sort field blank.

I've also noticed a second error message, Runtime 999999, the coordinates or measures are out of bounds.

Second Error Message

Command box and error message

closed as unclear what you're asking by PolyGeo Dec 17 '15 at 1:37

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to GIS SE! As a new user be sure to take the Tour to learn about how the site operates. Would you be able to edit your question to include more precise details of your workflow, please? For example, it sounds like you are using the Geoprocessing tool dialog to supply parameter values, but what are those values (a screenshot would help), and are you running this in the background or foreground, and while the dataset is represented by a layer in the table of contents or not? – PolyGeo Dec 9 '15 at 23:55
  • Making a couple of assumptions: 1) You are using a personal geodatabase and 2) you are actually naming the output layer the same as another layer in the geodatabase (clues being: "checked overwrite outputs" and "being told to overwrite files") I've encountered multiple errors trying to overwrite data using arcmap (from exporting a map .pdf to overwriting a layer) even when I check the box that I want to overwrite. My workaround is simply adding a prefix of suffix to the layer (usually a date increment layerX12092915, for example, so I know where to find the latest) – MaryBeth Dec 9 '15 at 23:55
  • It is likely one of the layers in your map – FelixIP Dec 9 '15 at 23:58
  • Angela, It is really convenient to export the results of your tool as a python snippet, then you can upload that snippet as a "code block" in an edit to this question above. That way we can all see what the GP Tool is doing. Just pick one run (from the Results tab) and convert/share it please. – JasonInVegas Dec 10 '15 at 0:32
  • Thank you for your suggestions! PolyGeo - Thank you, I've edited to description. It only takes about 20 seconds to run so I let it finish beofre moving on to anything else, is that what you mean by background/foreground? MaryBeth - yes, that was what I thought, but I have been making new filenames every time to avoid this. I made a new File Geodatabase so that it would be saving to a blank geodatabase where duplicates would be impossible, and this didn't help either. – Younie Dec 10 '15 at 17:56