4

This is what I am getting when I try to search in project layers and create a .qfts file to use quickfinder on a local shapefile.

An error has occured while executing Python code:

Traceback (most recent call last): File "C:/Users/xxxxxx/.qgis2/python/plugins\quickfinder\gui\configurationdialog.py", line 120, in createQFTSfile createFTSfile(filepath) File "C:/Users/xxxxxxxx/.qgis2/python/plugins\quickfinder\core\projectfinder.py", line 55, in createFTSfile cur.executescript(sql) OperationalError: table quickfinder_info already exists

Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version: 2.8.2-Wien Wien, 1b929ef

Python path: ['C:/Users/xxxxxxx/.qgis2/python/plugins\processing', 'C:/PROGRA~1/QGISWI~1/apps/qgis/./python', u'C:/Users/xxxxxxx/.qgis2/python', u'C:/Users/xxxxxxxx/.qgis2/python/plugins', 'C:/PROGRA~1/QGISWI~1/apps/qgis/./python/plugins', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\matplotlib-1.3.1-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\nose-1.3.3-py2.7.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\tornado-4.0.1-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\backports.ssl_match_hostname-3.4.0.2-py2.7.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\certifi-14.05.14-py2.7.egg', 'C:\PROGRA~1\QGISWI~1\bin\python27.zip', 'C:\PROGRA~1\QGISWI~1\apps\Python27\DLLs', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\plat-win', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\lib-tk', 'C:\PROGRA~1\QGISWI~1\bin', 'C:\PROGRA~1\QGISWI~1\apps\Python27', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\PIL', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\jinja2-2.7.2-py2.7.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\markupsafe-0.23-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\pytz-2012j-py2.7.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\win32', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\win32\lib', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\Pythonwin', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\Shapely-1.2.18-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\six-1.3.0-py2.7.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\xlrd-0.9.2-py2.7.egg', 'C:\PROGRA~1\QGISWI~1\apps\Python27\lib\site-packages\xlwt-0.7.5-py2.7.egg', u'C:/Users/xxxxxxxxx/.qgis2//python', 'C:\PROGRA~1\QGISWI~1\apps\qgis\python\plugins\fTools\tools']

3

I figured it out this morning, the version that QGIS downloads from the "manage and install plugins..." dropdown is not the 2.8.2 verison, it was the 2.7.5 version. So to fix the issue, you must go and download from the plugin creators site, the correct version of QGIS you are running, then put that into the same spot where the wrong version was placed. I had to install the plugin with the old version, and then replaced that with the new(correct version) folder "quickfinder". Then toggle the quickfinder off and back on in the "manage and install plugins..." dropbox. I was then able to save my .qfts file and go through the rest of the steps to make quickfinder work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.