1

I have an Excel Table with Lat/Long information. Its lat/long of this coordinate System: UTM zone 29n

My population density map instead is this coordinate system: UTM WGS84

Example: Barcleyville: Lon = 585242 / Lat = 517100


What I tried to do:

I loaded the pop_density data and changed the projection to WGS84 / UTM zone 29n : EPSG32629. Afterwards I loaded the CSV-Data with the same projection but it's still not overlapping. Do you have any suggestions?

2
  • 1
    Try using Save As... on the pop_density layer and save it as a new shapefile with the correct projection. Then load the new shapefile to see if it overlaps correctly.
    – Joseph
    Dec 11, 2015 at 13:07
  • Thats not working. Still the same problem. Dec 11, 2015 at 13:40

1 Answer 1

3

I think the issue is

I loaded the pop_density data and changed the projection to WGS84 / UTM zone 29n : EPSG32629.

Do NOT change the CRS in the layer properties! Just make sure that the pop layer is set to UTM WGS84, and the CSV layer to UTM zone 29n, and enable on-the-fly reprojection in the project properties.

4
  • I'm still waiting for a big warning inside the Set Layer CRS dialogie box. Most new users misunderstand that menu entry.
    – AndreJ
    Dec 13, 2015 at 6:22
  • 1
    Something like "Are you sure that you want to change the layer CRS? This does NOT reproject the geometries!"? With a "I understand what I'm doing, leave me alone!" checkbox :D
    – underdark
    Dec 13, 2015 at 9:42
  • Exactly! I'm sure most developers don't know what pitfall they offer here.
    – AndreJ
    Dec 13, 2015 at 13:11
  • @AndreJ I've started a thread on the qgis-ux mailing list
    – underdark
    Dec 13, 2015 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.