3

I need to reinstall GRASS 6.4 on this Ubuntu computer due to compatibility issues. I had installed GRASS 6.4 a few weeks ago to work with a simulation program. I used the command

apt-get install grass

as explained at the website https://grass.osgeo.org/download/software/linux/. Later I installed GRASS 7.1 to try to start making compatibility changes to the simulation. After doing this, the simulation no longer worked. I decided to try uninstalling all GRASS and reinstalling GRASS 6.4.

However, when I use the same command at the terminal, it only installs GRASS 7.0. I tried using a repository for GRASS 6, but that installed GRASS 7.1.

What is the simplest method I can use to reinstall GRASS 6.4?

4

First, to completely remove grass 7 you have to use:

sudo apt-get purge grass

or

sudo apt-get remove --purge grass

Afterward, you need to eliminate this repository of your /etc/apt/sources.list because it is the source of GRASS GIS 7.0 (stable):

ppa:ubuntugis/ubuntugis-unstable

and then:

sudo apt-get update
sudo apt-get install grass

to install the old grass 6.4

I hope that it helps.

  • This worked. There were some leftover GRASS 7 components after using the "purge grass" command, so I used Synaptic to delete those. Then, I followed the rest of the directions. GRASS 6.4 was installed correctly, and the simulation program is working again! Thank you for your help. – Will Dec 14 '15 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.