1

I created web map with qgis2web. Everything works fine but for all my attributes which are integer, the map shows the value "NULL". What can I do?

  • Openlayers or Leaflet output? – Tom Chadwin Dec 14 '15 at 13:14
  • Openlayers. It's working now. But I have no clue what changed. I tried it two more times and then it was okay. Btw: Is it possible to give an empty space "" when the value is "NULL"? – kevkev Dec 15 '15 at 13:59
  • I wonder if you updated the plugin. That might have fixed it. So you want a space when there is a null field? Can I ask why? – Tom Chadwin Dec 15 '15 at 16:34
  • not that I knew. I'd like the space because I have maybe 15 attributes, mostly only 2 or 3 have a value. It would just look nicer. Other option: Only show attributes which are not NULL. – kevkev Dec 16 '15 at 16:09
0

I've just committed two fixes for this to the master branch on Github, for nulls and integers, one for OL3, and one for Leaflet. The Autolinker library was preventing numeric OL3 output (now fixed), and it now explicitly catches nulls.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.