3

I am having some problems with the import of a locally saved osm file into arcmap 10.1. I have installed the Arcgis Editor for osm from here: http://www.arcgis.com/home/item.html?id=6a2a3c3cece749558393d4e80241ef51. I am using windows 10 64 bit. The arcgis 10.1 seems to work fine. I am trying with Download Extract Symbolize tool and this is the message it gives me.

enter image description here

There we go this is what happens when i try to load a locally saved OSM file with JOSM editor. enter image description here

3

Like hinted on by user two seven, you probably installed the 64-bit version of the OSM Editor toolbox, while not having "ArcGIS 64-bit background geoprocessing" installed. This will not work.

Reminder: you don't need the 64-bit ArcGIS Editor for OpenStreetMap to work with the toolbox on a 64-bit Windows. The 64-bit version is just meant to be used in combination with the "ArcGIS 64-bit background geoprocessing".

ArcGIS 64-bit background geoprocessing is a separate install for ArcGIS. You can either install that, or uninstall the 64-bit version of the ArcGIS Editor for OpenStreetMap toolbox, and install the 32-bit version of the editor toolbox, which should work with your version of ArcGIS having 32-bit geoprocessing.

  • I am sure i installed the 32 bit version of the tool , i just uninstalled and reinstalled it again. The problem still persists i get the same message. My arcgis 10.1 is a 32 bit version. I always run it as an administrator so i guess there are no permission problems since my user is an administrator.Any clue of what can cause this error , it is really frustrating. – Marian Pepa Dec 15 '15 at 20:57
  • 1
    Have you tried disabling background geoprocessing altogether? The option is in the Geoprocessing / Geoprocessing Options / Background Processing menu. De-select the "Enable" checkbox there. This will make sure all tools run in the foreground, that is, straight in ArcMap. – Marco_B Dec 15 '15 at 21:15
  • I disabled the background geoprocessing but it still didn´t work. Finally at last i tried to save the features and download the osm at the default geodatabase instead of a connected folder and guess what , it worked !! I will test it further just to be sure. – Marian Pepa Dec 17 '15 at 21:32
  • Marian, good to hear, but can you tell something more about your set-up. Is ArcGIS running on a "normal" local machine, or is it installed in a VMWare virtualized environment? – Marco_B Dec 19 '15 at 9:56
  • It is a normal desktop machine , pretty modest i would say, CPU Intel E5700 Ram 4GB DDR3 on windows 10 64 bit. A bit slow but for now that is all i got. And i was mistaken on what i said above about the background geoprocessing, in fact disabling it was the key. – Marian Pepa Dec 20 '15 at 12:11
1

Are there restrictions on the access of your Windows user profile in your organization? The error message indicates it can't get access to it, probably in an attempt to write out some temporary files.

You may need to ask your Windows system / network administrator.

Alternatively, did you have a second ArcMap session open, possibly pointing to the same datasource / file geodatabase? Close it, to be sure it doesn't put locks on it that may prevent access.

  • This is happening even in windows 7 in another pc. Same error same message. Even if i try to load another OSM file with the `Load OSM File´ tool wich i extracted with JOSM Editor it gives me an error : ERROR 001143 : Background server threw an exception. This is driving me crazy. – Marian Pepa Dec 15 '15 at 18:44
  • Disable background processing in geoprocessing options for the lower error. – If you do not know- just GIS Dec 15 '15 at 19:19
  • The top error appears to be permission / full disk sort of thing. – If you do not know- just GIS Dec 15 '15 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.