I am using FME workbench (trial version) to convert .DWG to .GDB (ESRI Geodatabase [file based]). I have mapped the Writer attributes with the exact Writer attributes. In fact, in the test database that we are using, there are only 5 fields with char(255) datatype, so no problems while mapping them.

Now when I run translation, it says 'Translation was SUCCESSFUL'. But also gives following warning:

During translation, some features were read that did not match a reader feature type in the workspace. This can happen if the reader dataset is changed, or a reader feature type removed or renamed.

If I test in ArcCatalog, the destination FeatureSet is created will all shapes, but WITHOUT fields mapped from Reader to Writer. If I preview table, it displays the table with all the rows with only Object_ID, Shape and Shape_Length fields, but not the attributes that were mapped from Reader to Writer.

I am aware that it might not be possible for you give any comments without having a look at the workspace. But can someone provide me some links to tutorials showing .DWG to .GDB conversion using FME workbench.

Thanks in advance

  • I am guessing you dn't have AutoCAD or Map3d. ?? are you using the ACAD or ACAD_OD reader? Are you using a single dwg file? Are you generating a worspace are starting with a blanK? what versions? – Brad Nesom Nov 30 '11 at 16:29
  • assuming ACAD are you just mapping the layer, color, linetype, linewidth to the gdb? – Brad Nesom Nov 30 '11 at 16:35
  • @BradNesom: I have AutoCAD Map 3D 2012 trial installed on my machine. I am starting a workspace from the blank. And, we are supposed to copy only features, their geometry and their attributes. – Kumar Kush Dec 1 '11 at 7:47
  • @Mark Ireland: I have managed to convert LINE and POLYLINE features use Mark Ireland's tips. Thanks man. But I am not able convert POINT features. In the log, I can see that all the features and attributes are read correctly from the source dataset (DWG), EXCEPT FOR THE POINT FEATURE I AM WORKING ON, including the other point features. And since the feature in question is not read, it is also not written. In the .GDB, only the attributes are created, NO ROW COPIED. I have tried different permutations of options in the writer. But can't get it working. Any other suggestions please? – Kumar Kush Dec 1 '11 at 8:06
  • 1
    To be precise, my source dataset is Autodesk AutoCAD Map 3D Object Data and the required destination dataset is ESRI Geodatabase (File-based). Hope this can help you understand what exactly what I want. – Kumar Kush Dec 1 '11 at 9:08

This message:

During translation, some features were read that did not match a reader feature type in the workspace. This can happen if the reader dataset is changed, or a reader feature type removed or renamed.

...should have nothing to do with how the data is written, just what is read. This FME Evangelist post should explain that part of the process.

With the attributes, one possible problem is that you aren't over-writing the original Geodatabase. ie once you run the workspace w/o creating the attributes, then future translations will never add them unless you overwrite the Geodatabase or at least drop the table. FME can create a table, but not modify one.

So, check in the Navigator window for a parameter to delete the geodatabase first, or open the Feature Type (table) properties dialog and click the Parameters tab for a parameter to drop the table first. Hopefully this will solve the problem.

enter image description here

enter image description here

  • Sorry for my last comment, but actually the Reader is NOT reading any POINT feature from the source DWG file. That's why it can't write anything in writer. All polylines features are converted properly. After consulting with a CAD knowing person, it looks like the point feature types are perhaps arranged as blocks. Now, can we open those blocks in FME Workbench or should I first extract/simplify the blocks in AutoCAD Map? – Kumar Kush Dec 1 '11 at 14:17
  • 1
    Check the Reader parameters (in the Navigator window again) and see what the settings are for "Expand Blocks into Entities" and "Preserve Insert Points". You would probably want expand blocks = No and preserve inserts = Yes. That might make a difference. Also check some of the advanced reader parameters for block-related functionality. – Mark Ireland Dec 1 '11 at 17:18
  • Thanks Mark! That worked. In addition of setting "Expand Blocks into Entities = No" and "Preserve Insert Points = Yes", I had to set "User Block Header Layer for Components = No" under Advanced or un-check "Use Block Header Layer for Components" in "Parameters" dialog-box while adding the Reader. – Kumar Kush Dec 2 '11 at 5:39
  • One general question regarding this message, "During translation, some features were read that did not match a reader feature type in the workspace.This can happen if the reader dataset is changed, or a reader feature type removed or renamed.". How can we find out what causes the error? We normally do map all attribute names and data types correctly, and still get the error message. – Kumar Kush Dec 2 '11 at 5:44
  • 1
    Well it's not really an error. It's just saying that some of the layers in the CAD file aren't defined in the workspace so will be dropped. It's not an error as such, because you may have set up your workspace like that deliberately. If you don't know what is missing then I'd use the Merge Filter option on a source feature type to let the data pass and you can then check it out. – Mark Ireland Dec 2 '11 at 20:12

You need to understand the CAD file format (DWG have many variants) and going to a folder based format (File Geodatabase).

Note: ArcGIS does need to be installed for conversion to ESRI Geodatabase formats. [But not shapefiles]

Here is a video from Safe Software last week [22nd November 2011] CAD to GIS formats


You will pick up on that workbench is much more than a data translation tool, it is an Manipulation Tool [hence the M in FME]

  • I am definitely new to CAD. I tried some simple conversions in FME Workbench (e.g. SHP to XML, SHP to MySQL, SHP to XLS) for testing, I was able to do that. ArcGIS 10 is installed on my machine. I watched the training videos, but they were not of much help. I will watch the video you mentioned and see if that can help. And yes, FME is definitely an excellent tool. That is the reason why our client has told us to use FME only. – Kumar Kush Nov 30 '11 at 15:55
  • I have watched the video you mentioned. Good video. But it doesn't have a section where conversion from .DWG to .GDB has been shown. Can you point me to a hint in the video which might help? – Kumar Kush Dec 1 '11 at 9:04

I think what you need to do is create the attribute fields (as User Attributes) in your target and then, if the target/source attributes are not named identically, you may have to explicitly map the source attributes to those new target User Attributes.

enter image description here

If you have a lot of attributes, you can also import attribute fields from the Writers menu:

enter image description here

  • I have created the attribute fields as User Attributes manually, matched the data types and made sure that input and output ports are green. – Kumar Kush Nov 30 '11 at 16:16
  • @kush.impetus - so you have 5 target fields of char(255) setup in target featureclass of the workspace, but they do not get created in the target file geodatabase featureclass upon workspace execution? – Chad Cooper Nov 30 '11 at 16:24
  • Right. Target feature class has 5 char(255) attributes because source feature set has 5 char(255) attributes. – Kumar Kush Nov 30 '11 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.