1

I'm trying to do a 'join field' in a model. When I do the join simply not in a model, no problem. When I try to use the 'join field tool' in a model, I get the ""<sheet> does not have OIDs.

I have a very simple feature class in a GDB, trying to join with an Excel sheet. No problem to join. Only in the model.

Anyone got a clue?

Both files comply with the 'join rules' in file names etc.

  • Can you post a screenshot of your model? – Stefan Dec 22 '15 at 15:19
2

Import your excel spreadsheet into the same gdb as your feature class, this should fix the "does not have OIDs" error. Your join should then work in the model

  • The Excelfile doesn't have an column OID. If you add it and populate it with unique numbers (starting at 1) this error will be solved. – Stefan Dec 22 '15 at 15:23
  • 2
    correct, importing it into the gdb will add the OID column – Maksim Dec 22 '15 at 15:24
  • Glad to help! Accept the answer if your problem was solved :) – Maksim Dec 22 '15 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.