6

I am getting the same problem as http://forums.arcgis.com/threads/19468-Opening-tools-causes-ArcMap-to-freeze-crash

That is, when I open any geoprocessing tool in ArcCatalog (might happen in ArcMap as well, though it hasn't to me yet), sometimes the application hangs. The timing of the hang occurs after the tool dialog opens but before it finishes drawing. I don't know exactly what conditions cause this to happen, but it feels random, maybe in 1 in 4 attempts it hangs.

For me, terminating the hung process and trying again sometimes works, sometimes it doesn't. But it's a huge headache.

Has anyone come across the same problem and found any resolution? I have already tried reinstalling ArcGIS. I think this started happening some time after installing SP3 for ArcGIS 10.

6
  • When did it start crashing? Any particular software you installed?
    – R.K.
    Feb 5, 2012 at 15:24
  • From memory nothing unusual stands out. I haven't had the problem since I deleted my geoprocessing history from my profile but I hesitate to call that the answer as I'm not 100% certain that's what fixed it.
    – blah238
    Feb 5, 2012 at 22:48
  • I lied, it's still happening, although it seems to happen more in ArcMap than ArcCatalog. Working with the mosaic dataset tools.
    – blah238
    Feb 6, 2012 at 21:20
  • Someone I know had a problem with random hangs with geoprocessing tools in ArcGIS 10, a system wipe and reinstall seemed to fix the problem. I'd hate to suggest it as a solution, though, and it doesn't really get to what's causing it. Just a thought I felt was worth sharing.
    – Lou
    May 3, 2012 at 20:39
  • I would recommend contacting ESRI Technical support. It could be a configuration specific issue or even a system specific issue. May 4, 2012 at 3:43

1 Answer 1

1

My ArcMap was crashing every time I tried to open any geoprocessing tool, or the toolbox itself. Was working fine for a week, until I auto-downloaded some updates last time I shut down the computer. Then all of a sudden I couldn't open the toolbox without crashing the program. After a very frustrating 4 hours, I fixed the problem. Not sure if this is the same thing you are experiencing, but maybe it will help others:

I reinstalled ArcMap and Python after de-activating a virus protection program a co-worker had installed (avast free antivirus program, seems like a crap program). I think what had happened was the security software had prevented a critical file from being downloaded and installed during the automatic update which was preventing python from running properly within ArcGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.