1

I used qgis2threejs to output 3d model with a dem and another viewshed output. I want to tick untick the layers for displaying and not displaying the layer.But the select unselect option in right window of qgis2threejs in not displaying and hiding the layers.

I used additional DEM option to integrate the additional layer in the output with display type Map canvas image.

[![on selecting viewShed the viewShed layer in not appearing][1]][1]

I want to tick/untick that option to show/hide the layers in the 3d model. I googled but could find the results.

I have created a model including that viewShed but the tick/untick option to hide/show the layer is the feature i want in the output.

1

Try this solution...

  1. Map Canvas and Layer Preparation

    • Hide viewshed analysis result from map canvas
    • Duplicate the elevation layer
  2. Settings for Background Layer

    • Select the original elevation layer in main DEM panel
    • Choose Map canvas image in display type group box
  3. Settings for Viewshed Analysis Result Layer

    • Check the copied elevation layer under additional DEM
    • Choose Layer image option in display type group box, click Select layer button and then check the viewshed analysis result layer in the Select layer dialog
    • Check Transparent background option
  4. Export

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.