All my work in QGIS is missing when i tried to export via pdf, jpg or impress (including scales, legends, maps, layers, georeferenced photos). I'm not using any "OpenLayers Plugin".

I had already tried to export by "Maps Printer" Plugin. The legends and scale are there, but the map no.

  • Well: I tried with "instant Print" plug in and it works fine. Just replace the map to the bluish zone and it's done!
    – user23570
    Jan 4, 2016 at 19:03

1 Answer 1


If you are trying to export to a PDF go to project->new print composer. Give this a title or leave it blank ->ok. Then go to Add New MapNew Map

Then drag your cursor across the blank template. Your paper size and printing setting are on the right side of the screen.

Then composer->export to pdf

  • that's what i did. But when exporting to pdf, the scales, legends, maps disapear!..and I had to re-start "composer to recover the maps and all the settings.
    – user23570
    Jan 4, 2016 at 22:50
  • What version are you running? How big of a map are you trying to export? Jan 5, 2016 at 15:36
  • 2.12. It's a very small map made from two photographs (after "georeferentitation")...just 14 hectares.
    – user23570
    Jan 5, 2016 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.