2

The attached image is the municipal basmap created using QGIS.

I was not able to add the grid coordinates in the print composer canvas.

How do I add those coordinates?

The attached image is the municipal basmap created using QGIS but was not able to add the grid coordinates in the print composer canvas

5

When you are in Print Composer you can select the map in the Item Properties tab and then scroll down to Grids where you click on the + button to add a grid. You can then modify the grid and it's frame. In your case you may just want the frame and no grid at all.

enter image description here

  • As far as I can see, you have to activate the grid in order to be able to display coordinates. Or have you found a way to draw coordinates when unchecking the "draw grid1 grid"-checkbox? – til_b Jan 5 '16 at 12:49
  • Aah, found it. It's in the "grid type" dropdown. – til_b Jan 5 '16 at 12:51
  • @iant In the interval unit under draw grid, it's showing millimeter and centimeter only and there's no meter as an option.The map that I have created should have coordinates like 121 26' 00" to 121 33' 00" for X then from 17 5' 00" to 16 50' 00" for Y. I have also selected under draw coordinates the format in Degree, Minute, Second and all the coordinates were selected to appear inside the frame but to no avail.Coordinates appears though it is shown I guess in centimeters which is somewhat the same to the image above you have posted. – Allan Jan 6 '16 at 8:35
  • 1
    I'm using Map Unit in my example which is degrees in my case, what projection is your map in? – Ian Turton Jan 6 '16 at 8:37
  • @iant I'm using EPSG:4326,WGS 84 Sir – Allan Jan 7 '16 at 1:04
1

Now I finally figured it out on how to add the correct Grid Coordinates on my Map.I manage the XY intervals that is be displayed by changing the intervals. Since my area is relatively small then I did not modify the degree (in lat/long coordinates are made up of degrees, minutes and seconds - minutes are made up of 60, and so are seconds, just like time). I modified the XY interval leaving the zero as it to the left of the decimal and work on the right of the decimal.In X and Y intervals I put 0.021000000000 and choose Frames and Annotations under Grid Type,under Grid Frame I choose Interior ticks for Frame style and the format of Grid coordinates is in degree,minute and second.Now, everything fall into places.

1

It's somewhat hidden in the "map properties" panel (in my QGis this is in the lower right of the composer window, when I have not selected any object in the composer) in print composer.

You have to add a grid to the map, then under the grid options there is the option to display coordinates.

You can disable the drawing of the grid lines using the "grid type" dropdown box. There you can select to only draw a frame and coordinates.

I cannot name the english names of the elements, because I have a german language QGis.

edit: I think I can reproduce your problem concerning millimeters and centimeters: when selecting EPSG:4326 as coordinate reference system, and choosing "map units" as interval units, coordinates are displayed as I expect. I can then choose to thisplay them as DMS coordinates as well.

When choosing "millimeters" or "centimeters", a grid is drawn at the specified millimeter or centimeter interval on the print composer map element. Now coordinates are shown as those specified millimeter values (starting from 0 in the bottom left corner). This does not make sense in your example. Those coordinates are not real world coordinates, but local coordinates relative to the bottom left corner of the map element in the print composer view.

If you really want meter-based coordinates, you'll have to reproject your data to a CRS that uses meter as the unit of measurement (UTM comes to mind, although I don't know which zone would apply).

  • In the interval unit under draw grid, it's showing millimeter and centimeter only and there's no meter as an option.The map that I have created should have coordinates like 121 26' 00" to 121 33' 00" for X then from 17 5' 00" to 16 50' 00" for Y. I have also selected under draw coordinates the format in Degree, Minute, Second and all the coordinates were selected to appear inside the frame but to no avail.Coordinates appears though it is shown I guess in centimeters. – Allan Jan 6 '16 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.