2

A recent convert to QGIS, I have versions 2.8.5 and 2.12.2 installed on my PC. The plugin Manager tells me I have v2,10.3 of the Processing plugin installed in the plugin folder of my local drive and v 2.12.2 is available in the official repository. When I try to upgrade I get the following error:

Plugin installation failed: failed to unzip the plugin package. Probably it's broken or missing ftom the repository. You may also want to make sure that you have write permission to the plugin directory: C:/Users..../.qgis/python/plugins

I have been able to successfully install other plugins and have manually tried copying the processing folder from a colleagues successful update into the plugin folder but the error persists.

Any idea what I'm doing wrong?

1

The processing plugin behaves a bit different from others.

It is now a core plugin, installed to C:\programs\<QGIS version>\apps\qgis\python\plugins, whereas plugins from the plugin manager get installed to C:\Users\<user name>\.qgis2\python\plugins. Additionally, there is a folder named C:\Users\<user name>\.qgis2\processing created even for the core version.

While the first is installed newly with every QGIS version, the plugin manager installs one for all.

I suggest to remove the second, and use the core function with the different versions of QGIS you have.

  • Thanks Mary and Andre. I wondered if it might be related to running multiple versions. I have tried removing all versions and re-installing just one at any one time but the error message persists. With just 2.8.5 installed QGIS reports that Processing plugin v2.6 is installed locally with 2.10.3 available from the official repository. With just 2.12.2 installed QGIS reports that Processing plugin v2.10.99 is installed locally with 2.12.2 available from the official repository. In each case QGIS seems to run so it may not be a problem as such?!? – David R Jan 6 '16 at 10:50
  • 1
    If you remove the repository plugin and ignore the upgrade message, all QGIS versions should run fine. – AndreJ Jan 6 '16 at 15:05
  • Thanks Andre. I will do just that. Advice much appreciated. – David R Jan 6 '16 at 15:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.