1

From time-to-time, I have the need to open tab files I have created in MapInfo with Google Earth Pro.

Aside from minor hiccups, I have never had an issue with importing a Tab file. The process I always follow in Google Earth Pro is:

File -> Open -> Select *.tab from File Type -> Select the file and pick the style template.

Recently, however, I have upgraded to MapInfo 15 (MapInfo 15.2 64-bit to be precise), and since then whenever I try to open a tab file in Google Earth, I only get the first item or 2 from the tab file and the remaining features (usually polygons) are lost. If I look at the tab in MapInfo, the data is present, so it seems MapInfo 15 is doing something differently that causes the tab file to not completely import into Google Earth Pro (GE version 7.1.5.1557).

Reverting to MapInfo 12 is not really an option, so is there anything else I can do to allow for Google Earth to completely parse these files?

To provide some additional details. I can take the MapInfo 15.2 created tab file and open it in MapInfo 12 without an issue on another machine. If I do "Save Copy As" from MapInfo 12 and create a new file, I can then open that file in Google Earth Pro just fine. But anytime I directly open a MapInfo 15.2 created tab file in Google Earth, I only get the first entry, sometimes 2 or 3. The remaining data is lost.

To add some additional info that I have come across recently, without upgrading either piece of software (still at the versions identified initially), I tried to open a list of locations identified by Lat/Lon that was created by MapInfo 15. There are 153 locations in the TAB file, but when I imported it into Google Earth, I got an error message from Google Earth saying:

Some features were not important due to invalid or out of range coordinates

and I only got 35 locations of the 153. All of the coordinates appear to be valid and there is only maximum span of just over 3 degrees for both Latitude and Longitude, so it seems illogical that there is actually something invalid in the TAB file (opening in MapInfo 12 and resaving it allows it to be imported to GE correctly without issue).

This is an example of a MapInfo 15.2 tab file that does not import completely into Google Earth

!table
!version 950
!charset WindowsLatin1

Definition Table
  Type NATIVE Charset "WindowsLatin1"
  Fields 2
    Column1 Float ;
    Column2 Float Index 1 ;
begin_metadata
"\MapInfo" = ""
"\MapInfo\TableID" = "31fb8af6-d29c-4c9c-a8ec-bf9e82e3b343"
"\MapInfo\ParentTableID" = "644f95b8-3201-4436-bdce-bdcff25c2a11"
end_metadata

If I take a file that I have opened and resaved via MapInfo 12, the contents of the TAB file are identical, even though it will correctly open in Google Earth

I'm not an expert in the structure of the MapInfo file formats, but this leads me to believe that the issue is in the DAT, ID, or MAP files. It's almost like Google hits the end of a line and thinks it is the end of the file. Was there any structure changes in the MAP or DAT files that could explain this behavior?

  • Have you tried using the Google Earth Link tool from within MapInfo Pro? I'm assuming that you are using Google Earth to open the file, right? – Peter Horsbøll Møller Jan 10 '16 at 13:51
  • @PeterHorsbøllMøller problem with the built in GELink is lack of flexibility, at least that I've found. When creating a KML by directly opening the *.tab in GE, you can specific the style template. I can't find any similar flexibility to do it via the GE Link tool. The subfolder options based on a specific field is extremely helpful for me so would require a lot of manual work to be able to replicate. – psubsee2003 Feb 24 '16 at 12:38
  • I'm not familiar with Google Earth Pro, so I can't say exactly why it can't read the MapInfo tables correctly. The GELink tools comes will full source code (it's part of the MapBasic installer) which can be found in this sub folder in your MapBasic installation folder: Samples\DOTNET\GoogleConnect – Peter Horsbøll Møller Feb 24 '16 at 14:12
  • Could you potentially share the header from the tab file you are trying to import? Open the tab file in a text editor and copy the lines until the column structure and just paste them into your question above. – Peter Horsbøll Møller Feb 24 '16 at 14:14
  • @PeterHorsbøllMøller added an example of a TAB file and some more details from what I've found recently – psubsee2003 Feb 24 '16 at 14:49
1

One thing to check is whether the table you try to open is a classic tab file (NATIVE) or the new Extended tab file (NATIVEX).

However, the Extended tab file can only be created with MapInfo Pro 15.2 64 bit.

The Extented Native table format has a number of benefits compared to the classic native table format: it supports file sizes larger than 2 GB and it does support Unicode (UTF-8 as well as UTF-16)

There is a preference where you can specify your preferred tab format that will be used when you create a new table (PRO > Options > System Settings): enter image description here

  • That's very helpful info, but unfortunately, the format is already "MapInfo" and not MapInfo Extended. – psubsee2003 Jan 8 '16 at 12:13
0

The work around I found was to save a copy of the file & then open the copy in Google Earth. I don't know what that works but it does.

  • Sorry, but this only works for me when the "Save Copy As" is done from MapInfo 12. Using MapInfo 15 to do this save step doesn't work for me. – psubsee2003 Sep 2 '16 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.