4

I am adding features to a shapefile point layer in QGIS 2.12 Lyon. When I add the new point I can see it, but once I click the Save Edits button it disappears. When I click Toggle Editing button to end my editing session it remains not visible. The point appears in my attribute table but it is not symbolized on the map. I am not using categories to symbolize the layer and the coordinate system matches that of my QGIS project. Why are my new points not being rendered?

  • 2
    Can you share the file with us to test? Does it happen with other files? Have you tried in a new empty project? – underdark Jan 7 '16 at 19:47
  • 1
    Does the timestamp on the file set (.shp/.shx/.dbf) actually change? – Vince Jan 7 '16 at 19:56
  • I've seen this happen in earlier versions of QGIS when the project spatial reference (canvas) is undefined, perhaps setting that might help though without an exact workflow I'm just stabbing in the dark. – Michael Stimson Jan 7 '16 at 21:27
  • How are your layer symbolized? Do you have set any filter on your layer? – Alexandre Neto Jan 7 '16 at 22:50
  • 1
    I have had a similar issue using 2.14.9 Essen. New features disappear once edits are saved. Saving the layer as a new shapefile temporarily resolves the issue, but if I try to edit it in another project the same issue occurs. Creating a spatial index/updating the extents seems to be a better fix. – JimS-W Jun 20 '18 at 11:00
5

It looks like you solved the issue, but as I had the same issue I'd like to elaborate.

My issue was with a shapefile created in Arc and edited in QGIS.

All edits appeared to be taking during the edit session, but new features would disappear when saved. Any features that were modified rather than created would render correctly. The records were present in the attribute table but no geometry was visible.

Zooming and panning to features (from the attribute table) panned to center of the layer extent. If snapping was enabled, it would snap to the vertices of the apparently missing features. The edits were still missing if the offending file was added to a new empty project.

If the shapefile was exported (saved as) a new file all of the edits would show up.

1

I came across the same issue and thought I'd share how I resolved it. The labels would disappear when the layer (shapefile) was saved, but only some of them, ones that I had additional position information within the attribute table.

The issue was the variable I created in the attribute table to hold the position data for the labels. I was using incorrect variables that were also too small to store the value. Once I redefined the fields in the layer properties as double real number variables, the issue was solved.

Although your issue may be different - look at your fields and ensure that they are of the correct type and length for what you have added or changed during your editing session.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.