1

I am having problems installing Anaconda with ArcGIS 10.1. My problem is specifically with pandas. ArcGIS python is my default python version. I installed python 0.16.2 in this version, which installed numpy 1.9.2. Following some posts, I created a .pth file (with ZZ as preffix, in order to read first the default version modules) and put it in C:\Python27\ArcGIS10.1\Lib\site-packages, which points to the Anaconda packages (C:\Anaconda2\Lib\site-packages). I can import most of the Anaconda python modules, but I have a problem with pandas. When I import pandas, I get the following error:

RuntimeError: module compiled against API version a but this version of numpy is 9

This only happens in a Windows command window, in ArcGIS python window imports the 0.16.2 version. The Anaconda pandas and numpy versions are 0.17.1 and 1.10.1. When I import the numpy version in a command window I get 1.9.2 (ArcGIS installed numpy version). The only problem is the error above with pandas, but after the error I check the version and says 1.9.2. I have read about creating environments in Anaconda, but I need the pandas 0.16.2 version because of some new funcionalities not present in older versions. I tried uninstalling the ArcGIS pandas version to use the Anaconda version, but I got the following error:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Anaconda2\Lib\site-packages\pandas\__init__.py", line 7, in <module>
    from pandas import hashtable, tslib, lib
  File "pandas\src\numpy.pxd", line 157, in init pandas.hashtable     (pandas\hashtable.c:38262)
ValueError: numpy.dtype has the wrong size, try recompiling

Does anyone how can I solve this problem?

  • 1
    I suspect that this question may be better researched/asked at Stack Overflow because the error that you have shown makes no mention of ArcPy or the Python installed by ArcGIS for Desktop. – PolyGeo Jan 11 '16 at 5:26
1

I solved the problem installing numpy 1.10. It seems the Anaconda pandas version was compiled with numpy 1.10, and the numpy default python version was 1.9.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.