5

I'm very new to QGIS, so apologies if this is a daft question. I've been trying to resolve my problem for a couple of days and I can't get anywhere. I have searched for similar issues here on SE but no-one seems to have the same problem.

I have a layer of forest habitat patches (green patches) and a boundary line layer (in purple). I want to determine which forest habitat patches are within certain buffers from that boundary line. I have used "Vector > Geoprocessing Tools > Clip" in order to create a new .shp with forest habitat patches within a buffer. I am getting inconsistent results, it seems to work for some distances...

Image 1

But in others it misses patches (highlighted by the red square)...

Image 2

Can anyone tell me why this might be happening? And any way to resolve it?

I have tried to construct workarounds using "Difference" and "Intersect" but I get other inconsistencies there as well.

I'm using QGIS 2.12.0, I have checked that all my shapefiles are in the same CRS, and checked that there are no Geometry errors.

2
  • Welcome to GIS:SE @EcologyTom! Would it be possible for you to upload your shapefiles to a public server so that others could test what's wrong?
    – Joseph
    Jan 11, 2016 at 14:46
  • 1
    Hi @Joseph I have uploaded the files to Filedropper, hopefully this link should work filedropperpro.com/filemanager/…
    – EcologyTom
    Jan 11, 2016 at 16:00

2 Answers 2

4

Right...it seems that there might be an issue with QGIS 2.12.0 (and QGIS 2.10.1) not processing your shapefiles correctly. I ran the clip tool in QGIS 2.8.2 and it seems to have worked (atleast for the area you have highlighted in your question):

  • The clipped layer using QGIS 2.10.1 and 2.12.0 (shown in red):

QGIS 2.12.0

  • The clipped layer using QGIS 2.8.2 (shown in green):

QGIS 2.8.2

It is rare for some tools in older QGIS versions to do better than the latest ones but for this instance, you could try downloading QGIS 2.8.2 and doing the same thing.

2
  • 1
    Took me a while to download 2.8.4, but it looks like the older version works for me as well, both in the example I posted in the original question and other areas where I was having similar problems. Thanks so much for your help, @Joseph!
    – EcologyTom
    Jan 11, 2016 at 20:41
  • @EcologyTom - Most welcome buddy, glad you got it to work :)
    – Joseph
    Jan 12, 2016 at 9:52
3

I don't work with QGIS, but I have had similar problems with ArcMap. Something simple I tend to forget...Make sure you have no attributes selected when running the tool.

I added your data...everything looks fine enter image description here

7
  • Thanks for the tip @Petunia but that doesn't seem to be the case in this instance.
    – EcologyTom
    Jan 11, 2016 at 15:27
  • Thanks for trying it out. Are there definitely no missing sections? I tried the process again after your answer, but I get the same problem. In the example files I've posted there is only one error (near the eastern edge - highlighted in the original post). There are lots more errors in the buffers closer to the boundary line. I can add the other buffer files if that might help?
    – EcologyTom
    Jan 11, 2016 at 15:49
  • I ran a 'clip' and had the same 147 attributes for 5km and 303 for 10km
    – Petunia311
    Jan 11, 2016 at 15:53
  • Yes, that's matches what I have, but the error is there.
    – EcologyTom
    Jan 11, 2016 at 16:02
  • Im not finding the area where the data is missing like your original photo.
    – Petunia311
    Jan 11, 2016 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.