2

I have a file path to an image file in an attribute table, eg;

C:\GIS\ScannedMaps\Map1.png

When I use the identify tool on the feature I can see the file path with the hyperlink lightening symbol next to it but when I double-click it nothing happens, 'right-click > View Hyperlink' has the same result. There are no error messages or anything, just nothing happens. I have set the display properties for that field to support hyperlinks and have the 'Document' radio button selected.

If you navigate to the image in windows you can open it (so nothing wrong with the image).

I have tried other image formats .jpeg .bmp with no luck.

However, If I change the file from an image to a .txt file stored in the same folder, the hyperlink function works perfectly, launching notepad.

So how do you view an image file?

  • The setup you've described sounds correct, and works for me in a simple test. Can you confirm the case sensitivity of the hyperlink - is the image file definitely .png and not .PNG? – Stephen Lead Jan 13 '16 at 22:49
  • I can confirm that the image is .png not .PNG. What application opened the image in your test? I think that could be my issue. If I open the image from the folder it opens in paint. – Cjd111 Jan 13 '16 at 23:08
  • Paint seems to be the only application on the machine that can open images. I have gone into control panel and set paint as the default program for these image types, still no result in ArcMap. – Cjd111 Jan 14 '16 at 0:39
  • I can reproduce this - it looks like a bug whereby ArcMap can't open Paint. Do you have the option Windows Photo Viewer? This is located in C:\Program Files\Windows Photo Viewer on my Windows 7 installation – Stephen Lead Jan 14 '16 at 0:52
  • Don't have Windows Photo Viewer as an option as I am working on a server not my local machine and it is not installed. But I think you're right its ArcMap not being able to open Paint. – Cjd111 Jan 14 '16 at 21:22
2

I'm able to reproduce the behaviour on ArcMap 10.2. With no other changes:

  • if the default Windows application for an image file is Windows Image Viewer, the link opens correctly in ArcMap
  • if the default Windows application for an image file is Paint, the link doesn't work

This seems to indicate that there is a bug in ArcMap 10.2 whereby a hyperlinked image won't open Paint. You could log this with Esri tech support at http://support.esri.com

0

I think you'll have to get this back into your database and tweek the hyperlink paths a bit. I'm assuming you're using some sort of database software and then joining the links using a unique attribute. Otherwise you'll have to try adding it in editor mode. First you could try adding /// before anything else in your file path, and if that doesn't work try using only two slashes. You may also have to reverse the other slashes in your link, but I've had success with this in the past doing this. I've attached some screenshots for reference...

enter image description here

enter image description here

I hope that helps. The slashes are what tells your computer that its going to open something local and not on a website.

EDITED: removed references to Excel and the screenshots that weren't necessary as per Stephen Lead's advice. Hoping to get the down vote removed as I really was trying to be helpful and don't have enough rep quite yet to simply comment and not post an answer.

  • 1
    I think the references to Excel are unnecessary here - the question doesn't mention Excel at all. And thanks for adding the screenshots, but they don't necessarily help to illuminate your answer. I'd suggest removing all but the final screenshot, and edit it to highlight the relevant sections, ie the Image_Path attribute – Stephen Lead Jan 13 '16 at 22:48
  • Probably a browser pop-up setting? – If you do not know- just GIS Jan 13 '16 at 23:23
0

You have to write the picture name along with picture format in attribute table field.

i.e if picture name is "12345" and format is ".JPG" then you need to write "12345.JPG"

This is the solution for your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.