2

I've just downloaded QGIS Lyon 2.12.1. The desktop application works great but the browser crashes whenever I try to view a csv data table. I've gotten it to work once out of ten tries. I click on the csv file and it just starts working...and never stops. The biggest file size I've attempted in 320 MB. Below you can see what I'm looking at:

Screenshot too: enter image description here Does it matter how big the files are? Seems like anything I try over 100 MB just won't work.

  • I've been having trouble with CSVs lately too with the latest QGIS and GDAL but haven't had time to dig into it. Can you try and reproduce the problem - that leads to some details that a dev can help with and this might be a potential bug report for either GDAL or QGIS. – SaultDon Jan 14 '16 at 3:48
  • All - me too... Felix - how big is the CSV? rows/columns/ disk space? – DPSSpatial Jan 14 '16 at 3:53
  • The size of the file normally would have an impact. I tried with QGIS 2.12.2 Browser (no GRASS) for a csv file of 4.21 MB and although it was slightly sluggish going through the attributes, it didn't crash for me. Perhaps give 2.12.2 a try? – Joseph Jan 14 '16 at 12:29
  • It's on my home computer so I'll check tonight. It's a pretty big file, 800,000 plus rows with about 20 columns. I'll post some more specifics tonight. – FelixTX83 Jan 14 '16 at 18:13
  • Sorry about the delay. Wife, kids, and full time over here. The biggest csv file I've tried to view in the QGIS browser comes 320 mb. Is that the problem? – FelixTX83 Jan 16 '16 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.