1

I'm working on a map of roads and rivers. For this map roads have names and rivers do not. I'd like to keep road names from overlapping the rivers. I'm working on a whole county with lots of places where roads and rivers cross. How do I keep those road names off the rivers?

I'm using Maplex for labeling. I don't actually want the rivers labeled at all so I tried putting in a blank column and labeling them with that, then giving it a really high feature weight, while dropping the road feature weight to zero. This didn't work and I'm not sure what else to do.

3

In the label settings for the feature where labels should not overlap (in this case, the rivers) the Feature Weight should be set to a number higher than 0. I believe Feature Weight is on the last tab of the label settings.

  • Thanks. I gave this a try, with the rivers Feature Weight at 50 and the roads at 0. They didn't change any (even after I restarted). – vt32 Jan 14 '16 at 19:47
  • The weight scale is 0-1000. Try putting the rivers at 1000 (max) and see if that does anything. If it still doesn't work, you might want to try the Standard labeling engine, because it has labeling and feature weights. – Baltok Jan 14 '16 at 19:55
  • Is "Place Overlapping Labels" unchecked on the Roads layers? – John Reiser Jan 14 '16 at 19:56
  • "Place Overlapping Labels" is unchecked. – vt32 Jan 14 '16 at 20:07
  • Great! putting the respective Feature Weights of Roads and Rivers to 1 and 1000 worked! When Roads were at 0 and Rivers at 1000 it didn't. Maybe 0 is a default that doesn't do anything? Regardless this worked, thank you! – vt32 Jan 14 '16 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.