1

I want to add a WMS layer from GeoServer to an OpenLayers website. However, when I try to load it into the website, I get following error in the console:

GET localhost:8080/geoserver/test/wms?%20LAYERS=test.put_25_vlak_1_vulling&SERV…=
&FORMAT=image%2Fjpeg&SRS=EPSG%3A4326&BBOX=-90,0,0,90&WIDTH=256
&HEIGHT=256 net::ERR_UNKNOWN_URL_SCHEME

I have tried to follow this link, but I suspect that I have made a syntax error somewhere.

Details are as follows:

workspace name: test layer name:put_25_vlak_1_vulling

    var map = new OpenLayers.Map('map');
    var wms = new OpenLayers.Layer.WMS( "World Map", "localhost:8080/geoserver/test/wms", 
    { layers:'test.put_25_vlak_1_vulling'
    } ); 
    map.addLayer(wms);
    map.zoomToMaxExtent();

Can somebody help me with this problem?

closed as off-topic by Ian Turton Jan 15 '16 at 13:46

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Ian Turton
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Try with http://localhost:8080/geoserver/test/wms – user30184 Jan 15 '16 at 12:22
  • ah yes! that worked, the error is gone. Still dont see anything but the error is at least gone. Now i only see pink rectangles – waywer Jan 15 '16 at 12:28