2

How can I debug the initial process of ArcMap 10.3.1 for Desktop?

The ARCMAP.exe process get's killed after hanging a while with the "Loading Document..." message.

enter image description here

What I have done so far:

  • Check and reset the Normal.mxt
  • Reset AppData\Roaming\ESRI\Desktop10.3
  • reinstall ArcGIS 10.3.1

It seams like something is blocking the initialing process. Interesting is that the process gets about ~100000 - 160000 K memory and then doesn't change anymore until it get killed.

arcgis process

Any ideas how to debug the start of ArcMap?

(sorry for cross posting, s. geonet.esri.com)

  • If you open Categories.exe, do you see any non-Esri extensions in ESRI Mx Extensions? – Kirk Kuykendall Jan 20 '16 at 16:18
  • are you trying to open direct to a MXD file, or just loading an empty ArcMap? – Midavalo Jan 20 '16 at 19:07
  • @KirkKuykendall I removed everything before the reinstall. There was a ET GeoTools from ArcMap 10.0 which I deinstalled too. I'll check the categories.exe tomorrow. @Midavalo I tried everything, the normal.mxt another MXD and just a to open the arcmap.exe directly... – wittich Jan 20 '16 at 21:38
  • @KirkKuykendall when I start categories.exe I see a bunch of extentsions with random names, AGS Proxies and QGISDataProvider. All the other extensions start either with the name Esri or ESRI! – wittich Jan 22 '16 at 12:37
  • 1
    Did you try the step in this doc? support.esri.com/en/knowledgebase/techarticles/detail/45924 – kenbuja Jan 22 '16 at 14:08
2

Description

ArcMap unexpectedly exits during the "Loading Document..." stage on startup. No error code is displayed. Cause

This can result from an upgrade to Python 2.7.11, which was released on December 12, 2015.

In the newly released version, there is a line in the code that makes the following statement, where 'PyWin_DLLVersionString' now is "2.7-32".

This statement searches for the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Python\PythonCore\2.7-32\PythonPath, which does not exist.

source: http://support.esri.com/technical-article/000012670

THIS IS WHAT SOLVED MY PROBLEM

  • I updated to python 2.7.12 and it worked! Tried everything else and this one the one and easy fix! – Evan B Sep 22 '16 at 0:35
0

I have simmilar issues - ArcMap 10.3.1 hangs on startup "initializing application" phase.

Solution:

  1. Rename C:\Program Files\common files\ArcGIS\bin\ArcGISConnection.exe if it does not help

  2. Reset profile: https://geonet.esri.com/thread/78692

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.