1

I'm creating an FME workspace to copy a line feature class from an ArcSDE database to PostGIS. I've been getting the error Column has Z dimension but geometry does not. It turns out the "Z-dimension" is actually referring to M-values (for routing purposes). I don't need them in the target database so I'd like to just keep them out of the transformation for now. Does anyone know how to do this in FME? I don't see any settings in my reader or writer.

1
1

As @Mapperz has indicated, you should use the MeasureRemover. You can specify the name of the measure (if known), or you can remove all measures from the features.

enter image description here

If it is in fact Z-values that you need to remove, then the 2DForcer is the transformer to use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.