3

I've been testing the Incremental Network Loader tool for loading new lines into a geometric network from an outside feature class. The tool worked perfectly on a File GeoDatabase copy of our SDE. Next, I tested the same process on a test version from our ArcSDE. Using the same workflow with the same line file, the tool ran and gave no errors, but none of the new lines appear in the network.

Any ideas why the tool isn't loading into the SDE (versioned) geometric network?

  • I've also had the same experience. Could never get it to work loading into SDE (I gave up) – Midavalo Jan 21 '16 at 17:24
  • @Midavalo - Did you test on DEFAULT, or were you only using versions? – Priscilla Jan 22 '16 at 20:53
  • I don't recall, but I suspect I tried both to DEFAULT and into a version. My geonetwork data is versioned. I will test again and report back. – Midavalo Jan 22 '16 at 20:56
  • @Midavalo Thanks for looking into this! I've requested IT to make me my own SDE so I can run tests on DEFAULT, separate from production. It looks like I'll have to wait until Monday or Tuesday, so let me know if you learn anything first. – Priscilla Jan 22 '16 at 21:55
  • I'm going to have to do more testing. I tested into DEFAULT and into a separate version off DEFAULT, both failed to load any features (although no errors were reported). I tested into a file geodatabase and they loaded successfully. I then tested into a personal SDE instance on my local PC, into DEFAULT version, and it successfully loaded the features! So now I wonder if there is a fault in loading into Enterprise SDE. – Midavalo Jan 24 '16 at 19:12
3

The Incremental Network Loader tool works for file geodatabases and personal SDE instances, but appears to have a bug for loading into SDE's, default or version. We're reporting this bug to ESRI.

Alternatively, I found two other methods for accomplishing the data load into my SDE version:

  1. Append Tool - quick and new features were snapped to the geometric network
  2. Object Loader - slower, but also gives you options about the snapping environment and validation rules. All new features snapped to the network nicely.
  • If Esri issue a bug number (I think they still start with NIM) then be sure to edit it into your answer. – PolyGeo Feb 11 '16 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.