The goal is to make converting scanned paper maps to map tiles as easy as possible.

I've done a few, but the slow part is manually entering coordinates of points. What I'd like to do is for each point on the scanned paper map, click on a satellite image (ie a Google Map) to automatically set its coordinates. I know this should be possible with QGIS and the georeferencer plugin (I'm using 1.7.2) but...

If I set QGIS to use WGS84 projection, I haven't found a way to display Google Maps in QGIS so that the georeferencer plugin tool will take coordinates from it.

If I set QGIS to use EPSG:900913, I can use the Openlayers plugin to add a Google Maps layer, and the georeferencer plugin tool happily takes coordinates from it. But gdal2tiles won't process the resulting geotiff file that georeferencer produces.

So currently I set QGIS and georeferencer to use WGS84, type in lat/lon pairs manually, and then gdal2tiles processes the resulting geotiff successfully.

Has anyone found a workflow that avoids the problems I described above?

Thanks & regards, David

  • 1
    a) you can't reproject layers from the "openlayers plugin", this because the provider (Google, Bing, Yahoo, etc.) does not allow it. b) "gdal2tiles won't process the resulting geotiff" is a bit too vague. What do you mean? Dec 11, 2011 at 22:50
  • Giovanni, thanks for the reply. a) Do you know if there is any way to get a google map in QGIS that returns lat/lon values to the georeferencer when I click a point? When I type in the lat/lon pairs manually, I'm reading them off a Google Map displayed in OpenLayers (eg mouse over gwulo.com/node/9285 to see lat/lon in lower-right corner). I'd like those to automatically be fed into the Georeferencer. Hopefully the question makes sense - I'm not 100% clear how this all works!
    – user5113
    Dec 12, 2011 at 6:02
  • b) When I open the scanned map (a JPG file) in the Georeferencer, I specify EPSG:900913 as the projection. Then for transformation settings I specified WGS84 as the target SRS. After georeferencing I run gdal2tiles on the resulting file, but no tiles are generated: 'ERROR 1: Too many points (30976 out of 30976) failed to transform, unable to compute output bounds. ERROR 1: Invalid dataset dimensions : 0 x 61140008 ERROR 1: Invalid dataset dimensions : 0 x 61140008'
    – user5113
    Dec 12, 2011 at 6:33
  • b2) For transformation settings I specified EPSG:900913 as the target SRS. After georeferencing I run gdal2tiles on the resulting file. Tiles are generated, but when I view the sample Openlayers map from gdal2tiles, the map is centred on the wrong location, and there is no sign of any tiles. regards, David
    – user5113
    Dec 12, 2011 at 6:34
  • As a minor point, EPSG:3857 is preferred over EPSG:900913, they both represent the same projection, but 3857 is an "official" designation. (For varying levels of official...) Dec 12, 2011 at 16:45

1 Answer 1


As already said, you cannot reproject layers from the "openlayers" plugin, but you can indeed use them as overlay to georeference another raster image. When finalizing the operations the georeferencer will ask you for a number of parameters, among the other "Target SRS", this means that you can use a map in a certain coordinate system (ex: 900913) to georeference another one, and have the output automatically warped in another one (ex: WGS84).

You can do also the other way: create your GCPs in WGS84, translate them in 900013 and then use them to georeference the map.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.