1

I have a feeling I know the answer to this but want to make sure before I start redoing all the work.

I've recently started using QGIS to help with mapping of an estate. Last week a created a new vector polygon layer (and associated shapefile) to map the woodland. By Friday afternoon I'd completed the mapping and entry of all the attributes for each polygon.

I opened up QGIS this morning to show a colleague the progress and the layer is at a point I reached on Thursday afternoon. All my updates (the bulk of the work) made on Friday aren't there. The confusing bit is that when I check the underlying shapefiles in Windows Explorer the .dbf .shp .sxh files are all showing a last modified date of 1638 on Friday, when I last saved before the weekend.

I've tried creating a new vector layer based on these but with no success.

Update - I've now recreated all the polygons and associated attributes. But have been thinking more about what could have caused the original issue. If I had only been saving layer edits during the Thursday and Friday and then not saved the project before going home on Friday, could this have potentially caused the issue? I can't be certain this is what I did but trying to find an explanation so I can avoid it in the future.

  • Have you tried opening the shapefile in a new QGIS instance? I encounter this behaviour sometimes with shapefiles that are stored on SAMBA shares, where the created features are still there but won't display in QGIS until re-importing the shapefile. – Kersten Jan 25 '16 at 13:00
  • Did you open in LibreOffice/OpenOffice the DBF to see if attributes are as you expect (e.g Friday last work)? To confirm if your issue is QGIS reading related or not? – ThomasG77 Jan 25 '16 at 13:03
  • Thank you both. Kersten - I tried your suggestion and unfortunately it made no difference. ThomasG77 - I was just in the process of opening it in Excel and unfortunately the underlying data is as Thursday's work. I'm not sure what has happened but the file modified is definitely 22nd Jan but the data within in it is the 21st. Interestingly the modified date on the parent folder is the 21st. Looks like something has gone wrong at the OS level rather than QGIS. – JayBM Jan 25 '16 at 13:23
  • Does the vector shapefile that you have now preserve the completed map you were working on on Friday? If the attribute table is the only thing missing, you could just work on that and then perform a relate/join table function to complete the shapefile. Might be less work. – Trevor J. Smith Jan 25 '16 at 14:44
  • 1
    Hi Joseph, no it's a standalone installation with no sharing. Although the shapefiles are saved in a folder structure that is part of my MS OneDrive setup. – JayBM Jan 29 '16 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.