5

I'm using QGIS 2.12 and trying to load the following WMTS layer http://geoappext.nrcan.gc.ca/arcgis/rest/services/BaseMaps/CBME_CBCE_HS_RO_3978/MapServer/WMTS/1.0.0/WMTSCapabilities.xml

from http://geoappext.nrcan.gc.ca/arcgis/rest/services/BaseMaps/CBME_CBCE_HS_RO_3978/MapServer

When I add a new WMS layer in QGIS I can connect to the server and add the desired layer but the layer doesn't load. I'm stuck with a blank page.

  • 1
    Looking at the metadata, there seems to be issues with the layer's Right bounds column. Perhaps this has something to do with the blank image...? – Joseph Jan 27 '16 at 15:14
4

When this happens to me, it's usually one of the following:

  • try "zoom to content" on the layer, to adjust your bounding box
  • check, if your CRS in QGIS matches the one, you load from the WMS
  • try zooming in, as layers may have a styling rule to be only shown at a certain zoom level

EDIT:

Took a further look at the service and tried to get plain tiles but that didn't work:

By KVP params:

http://geoappext.nrcan.gc.ca/arcgis/rest/services/BaseMaps/CBME_CBCE_HS_RO_3978/MapServer/WMTS?SERVICE=WMTS&REQUEST=GetTile&VERSION=1.0.0&Layer=BaseMaps_CBME_CBCE_HS_RO_3978&Style=default&Format=image/png&TileMatrixSet=default028mm&TileMatrix=16&TileRow=1000&TileCol=1000

By tile index:

http://geoappext.nrcan.gc.ca/arcgis/rest/services/BaseMaps/CBME_CBCE_HS_RO_3978/MapServer/WMTS/tile/1.0.0/BaseMaps_CBME_CBCE_HS_RO_3978/default/default028mm/16/1000/1000.jpg

It just gives empty tiles. Maybe it's about the service provider in this case.

EDIT:

Somehow, the tileindex seems to be messed up. I had a look at the tiles, your esri web application uses. You could check it by using developer tools in your browser (F12). One sample tile is

http://geoappext.nrcan.gc.ca/arcgis/rest/services/BaseMaps/CBME_CBCE_HS_RO_3978/MapServer/tile/17/32151/28699

You also get it from the service with the KVP-syntax:

http://geoappext.nrcan.gc.ca/arcgis/rest/services/BaseMaps/CBME_CBCE_HS_RO_3978/MapServer/WMTS?SERVICE=WMTS&REQUEST=GetTile&VERSION=1.0.0&Layer=BaseMaps_CBME_CBCE_HS_RO_3978&Style=default&Format=image/jpeg&TileMatrixSet=default028mm&TileMatrix=17&TileRow=32151&TileCol=28699

But if you compare this with the tile indices, given in the capabilities document, those tiles are way out of the given tile matrix bounds, which is Columns: 5140 Rows: 4717 for matrix level 17

  • server does not see, to be sown since you can see the layer in arcgis.com map link – Ariel Jan 28 '16 at 14:13
  • It seems that you found the problem, however I do not fully understand what the problem is. Can I do something about this or is it a server problem ? thanks – Ariel Feb 1 '16 at 15:12
  • Actually, this is more a description of the effects. To be honest, I also don't know, what's the real cause or problem for this. Maybe someone else here has a better understanding of arcgis services which may help. I think, the point, why the esri web-UI works, is because they are accessing the raw tiles, not the WMTS, which seems to be broken. Also the comment by Joseph seems to be reasonable. Could be helpful, to investigate those east bounds column for correct values (see layer properties in QGIS). – ulrich Feb 1 '16 at 20:54
  • @Ariel: just found a possibility which might allow you to load the raw tiles from the ArcGIS map server: http://www.3liz.com/blog/rldhont/index.php?post/2012/07/17/OpenStreetMap-Tiles-in-QGIS. Never tried this myself though in QGIS. You should check, if you are allowed to do so, I think providers like google, bing etc. prevent you from accessing raw tiles. – ulrich Feb 3 '16 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.