I have downloaded MODIS MOD10A2 8 day snow cover image. I need to subset this image. I tried to subset the image in erdas. it says the AOI layer is empty.

  • As a relatively new user please take the tour and review the help center that it leads onto. Here you are effectively asking two questions i.e. how to do this using ERDAS and how to do this using ArcGIS, and so your question is too broad. Also, questions here are expected to include a detailed description of what has been tried so far. – PolyGeo Feb 2 '16 at 5:22
  • 1
    Your edit helps narrow this question down, thank you! Have you checked the projections of your AOI and MODIS image? – Erica Feb 2 '16 at 12:38
  • The MODIS image is in sinusoidal projection and AOI in UTM WGS84. But i changed MODIS projections to UTM WGS84. – Ankit Tewari Feb 4 '16 at 5:04

I think its displaying as empty because you haven't selected the AOI layer after creation. Here are the steps below.

1.Add vector layer to your viewer. Keep in mind the Erdas shows available layers in the native .img format, so you'll need to select the appropriate file type (.shp in my example).

  1. Once the vector is displayed. Click on it. The selected vector will turn yellow to show you have selected it.

enter image description here

  1. Once selected, click on the home tab and navigate and click on to Paste From Selected Object. This creates the AOI layer you can use to subset your raster. enter image description here

4 Click somewhere in the middle of the polygon and bounding characteristics will be shown. Be careful, though since you can accidentally move or alter your AOI's geometry.

enter image description here

  1. Go to raster, create subset imageenter image description here

  2. Go to the bottom of the subset menu and click on AOI. Select Viewer as the option in the Choose AOI menu.enter image description here

  3. Save output file and execute Subset. This should "clip" the raster to the vector geometry.enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.