4

When uploading a feature layer to ArcGIS Online, and then accessing it via ArcGIS Online's REST API, there is a limit of 1000 features returned.

Is it possible to increase the limit and return more than 1000 features?

0

1 Answer 1

7

The workflow is outlined here at HowTo: Update the maximum record count for feature services in ArcGIS Online.

  • Log in to www.arcgis.com with administrator credentials
  • Click My Content, and navigate to the intended feature service
  • Open the feature service. In the item details page of the feature service, click the hyperlink under 'Layers'. The ArcGIS REST Services Directory page opens
  • Modify the URL by appending 'admin' to the end of the URL and deleting the rest of the URL to the service: http://services.arcgis.com/xxxx/ArcGIS/admin
  • Click Enter to access the new page
  • Click Services and find the intended service. Click the service name. The URL becomes: http://services.arcgis.com/xxxx/ArcGIS/admin/services/states.FeatureServer
  • Scroll to the bottom of the page, and click Update Definition
  • Change the value of the 'lastEditDate' key to null.
  • Search for the maxRecordCount parameter
  • Change all the default values of 1000 to the number of desired features records to display
  • Click Update Service Definition
  • Go back to the 'My Content' page and open the feature service in a new web map. All features beyond 1000 are now included and displayed as desired.
4
  • I'm finding that the second maxRecordCount value isn't being persisted after hitting Update Service Definition - I'll follow it up with Esri tech support Feb 3, 2016 at 3:21
  • I can vouch this process works for me. Let me know if support have trouble with the ticket.
    – jakc
    Feb 3, 2016 at 9:38
  • 1
    @Simon my instance of ArcGIS Online is currently a trial - when I tried it on a paid instance it worked as expected. Thanks Feb 9, 2016 at 5:37
  • Strange limitation to put on a trial account. Good to know.
    – jakc
    Feb 9, 2016 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.