1

I'm creating a series of maps in print composer from the same basemap (from the quickmapservices plugin) in QGIS 2.12.2. Sometimes this works, though it only allows the scale to be in metres, feet or nautical miles and not km, which is not ideal, however other times the numbers bunch up over each other such that they are not readable (see image below). How can I prevent this?

Bunched up scale bar

3

I used to automate layout generation through atlas back on 2.6. It generates per feature layout on a shp. I assume your scale bar looked like that when the automation meet a feature that is too large compared to other feature that exist within one shp. I assume the automation process are similar between atlas and plugin that you are using. To avoid such scalebar, you can try to find an option to set the generated layout use fixed scale (which will vary your feature per map, some are close enough to map edge, some are not). the fixed scale need to be set to a number so your largest feature can still be contain on the layout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.